Commit 2f023b90 authored by Boudewijn Rempt's avatar Boudewijn Rempt

Update to ECM 1.1.0

And ask for a bunch of ECM modules. Because of a total lack of documentation,
I'm cribbing from kate her.
parent 4db3784b
......@@ -147,8 +147,19 @@ calligra_set_productset(${PRODUCTSET})
#########################
########################
find_package(ECM 0.0.11 REQUIRED CONFIG)
find_package(ECM 1.1.0 REQUIRED NOMODULE)
set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR})
include(ECMOptionalAddSubdirectory)
include(ECMInstallIcons)
include(ECMSetupVersion)
include(ECMMarkNonGuiExecutable)
include(ECMGenerateHeaders)
include(GenerateExportHeader)
include(ECMMarkAsTest)
include(CMakePackageConfigHelpers)
include(WriteBasicConfigVersionFile)
include (CheckFunctionExists)
include(KDEInstallDirs)
include(KDECMakeSettings)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment