Commit af85f009 authored by Boudewijn Rempt's avatar Boudewijn Rempt

We need libheif 1.2.0 minimum

parent 88e9c007
......@@ -57,10 +57,8 @@ if (APPLE)
add_definitions(-mmacosx-version-min=10.11 -Wno-macro-redefined -Wno-deprecated-register)
endif()
if (LINUX)
if (CMAKE_COMPILER_IS_GNUCXX AND NOT CMAKE_CXX_COMPILER_VERSION VERSION_LESS 4.9 AND NOT WINDOWS)
add_definitions(-Werror=delete-incomplete)
endif()
if (CMAKE_COMPILER_IS_GNUCXX AND NOT CMAKE_CXX_COMPILER_VERSION VERSION_LESS 4.9 AND NOT WIN32)
add_definitions(-Werror=delete-incomplete)
endif()
######################
......@@ -532,7 +530,7 @@ set_package_properties(GIF PROPERTIES
TYPE OPTIONAL
PURPOSE "Required by the Krita GIF filter")
find_package(HEIF)
find_package(HEIF "1.2.0")
set_package_properties(HEIF PROPERTIES
DESCRIPTION "Library for loading and saving heif files."
URL "https://github.com/strukturag/libheif"
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment