Commit ea2bd83b authored by Pino Toscano's avatar Pino Toscano

cmake: fix version spec for find_package

in case a minimum version is required, it must be the second parameter,
before the "REQUIRED" keyword
parent 19de1d3f
......@@ -500,7 +500,7 @@ endif()
##
## Test for eigen3
##
find_package(Eigen3 REQUIRED "3.0")
find_package(Eigen3 3.0 REQUIRED)
set_package_properties(Eigen3 PROPERTIES
DESCRIPTION "C++ template library for linear algebra"
URL "http://eigen.tuxfamily.org"
......@@ -509,7 +509,7 @@ set_package_properties(Eigen3 PROPERTIES
##
## Test for exiv2
##
find_package(Exiv2 REQUIRED "0.16")
find_package(Exiv2 0.16 REQUIRED)
set_package_properties(Exiv2 PROPERTIES
DESCRIPTION "Image metadata library and tools"
URL "http://www.exiv2.org"
......@@ -518,7 +518,7 @@ set_package_properties(Exiv2 PROPERTIES
##
## Test for lcms
##
find_package(LCMS2 REQUIRED "2.4")
find_package(LCMS2 2.4 REQUIRED)
set_package_properties(LCMS2 PROPERTIES
DESCRIPTION "LittleCMS Color management engine"
URL "http://www.littlecms.com"
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment