Commit 5c108eac authored by Alvin Wong's avatar Alvin Wong

Remove openssl requirement in ext_qt

The ext_openssl build in its current state does not work on Windows,
therefore the OpenSSL dependency of Qt cannot be satisfied.

Partially reverts 0fc1a756 (D15585)
parent 24d1e547
......@@ -13,7 +13,7 @@ if (WIN32)
#
-qt-zlib -qt-pcre -qt-libpng -qt-libjpeg
#
-opensource -confirm-license -openssl-linked
-opensource -confirm-license
#
-release -platform win32-g++ -prefix ${EXTPREFIX_qt}
QMAKE_LFLAGS_APP+=${SECURITY_EXE_LINKER_FLAGS}
......@@ -41,8 +41,6 @@ if (WIN32)
COMMAND ${PATCH_COMMAND} -p1 -d qtbase -i ${CMAKE_CURRENT_SOURCE_DIR}/0004-Fix-debug-on-openGL-ES.patch
COMMAND ${PATCH_COMMAND} -p1 -d qtbase -i ${CMAKE_CURRENT_SOURCE_DIR}/0005-cumulative-patch-for-hdr.patch
CMAKE_ARGS -DOPENSSL_LIBS='-L${EXTPREFIX_qt}/lib -lssl -lcrypto'
INSTALL_DIR ${EXTPREFIX_qt}
CONFIGURE_COMMAND <SOURCE_DIR>/configure.bat ${_QT_conf}
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment