• Andreas Cord-Landwehr's avatar
    Adapt to KNewStuff API change in 5.63 · de8870b0
    Andreas Cord-Landwehr authored
    Two changes are needed to be compatible with KNewStuff > 5.62:
    - the installItem call now requires two arguments (previously this with
      only the first)
    - binding the items model to the engine property does not work anymore
      but binding it directly to the engine object solves the issue
    
    Note that this is a runtime only issue because QML methods are used.
    However, this patch increases the minimal required version to 5.63 for
    all frameworks, which shall help to ensure a functional KNewStuff
    version being present.
    
    BUG: 414985
    de8870b0
DownloadPage.qml 5.29 KB