Commit 749709e8 authored by Laurent Montel's avatar Laurent Montel 😁

GIT_SILENT: Use KF5_MIN_VERSION as KF5_VERSION will be overridden by first KF5...

GIT_SILENT: Use KF5_MIN_VERSION as KF5_VERSION will be overridden by first KF5 find_package version as Found by Andreas Sturmlechner
parent 17b3786a
......@@ -4,17 +4,17 @@ cmake_minimum_required (VERSION 2.8.12 FATAL_ERROR)
# minimal Qt requirement
set(QT_MIN_VERSION "5.9.0")
set(KF5_VERSION "5.46.0")
set(KF5_MIN_VERSION "5.46.0")
# ECM
find_package (ECM ${KF5_VERSION} REQUIRED NO_MODULE)
find_package (ECM ${KF5_MIN_VERSION} REQUIRED NO_MODULE)
# where to look first for cmake modules
set (CMAKE_MODULE_PATH ${ECM_MODULE_PATH})
find_package (Qt5 ${QT_MIN_VERSION} CONFIG REQUIRED Core Widgets Svg)
find_package (KF5 ${KF5_VERSION} REQUIRED COMPONENTS
find_package (KF5 ${KF5_MIN_VERSION} REQUIRED COMPONENTS
I18n XmlGui GuiAddons DocTools DBusAddons Crash
)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment