Commit bb62b071 authored by Nikita Sirgienko's avatar Nikita Sirgienko

[Octave] Change graphics toolkit only if currect toolkit is "fltk". This is...

[Octave] Change graphics toolkit only if currect toolkit is "fltk". This is needed for preventing problem with modern octave versions (5.0.0+), some of which have "qt" toolkit as default.
parent fe60f154
......@@ -104,7 +104,7 @@ void OctaveSession::login()
args << QLatin1String("--eval");
args << QLatin1String("set (0, \"defaultfigurevisible\",\"off\");");
args << QLatin1String("--eval");
args << QLatin1String("graphics_toolkit gnuplot;");
args << QLatin1String("if strcmp(graphics_toolkit(), \"fltk\") graphics_toolkit(\"gnuplot\") endif;");
}
else
{
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment