Commit 2f3ffbd3 authored by Pino Toscano's avatar Pino Toscano
Browse files

scripting: remove support for Python < 3

It was sort of required already in previous commits, so remove a code
branch that is not needed anymore.

Followup of commit 1fdeff25.
parent b10b1a88
......@@ -390,11 +390,7 @@ PythonScripter::PythonScripter()
// the newstring stuff is to prevent warnings about conversion from
// const char* to char*..
char* s = newstring( "kig" );
#if PY_VERSION_HEX >= 0x03000000
PyImport_AppendInittab( s, PyInit_kig );
#else
PyImport_AppendInittab( s, initkig );
#endif
// we can't delete this yet, since python keeps a pointer to it..
// This means we have a small but harmless memory leak here, but it
// doesn't hurt at all, since it could only be freed at the end of
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment