Commit 763e9a7f authored by Eckhart Wörner's avatar Eckhart Wörner

krazy: Check for Qt classes that should not be used (2 issues)

* QTextEdit[KTextEdit]

svn path=/trunk/KDE/kdeedu/kmplot/; revision=902690
parent 9695a9b0
......@@ -28,8 +28,9 @@
#include "xparser.h"
#include <KLocale>
#include <KTextEdit>
#include <QScrollBar>
#include <QTextEdit>
#include <QVBoxLayout>
//BEGIN class Calculator
......@@ -45,7 +46,7 @@ Calculator::Calculator( QWidget * parent )
QVBoxLayout *layout = new QVBoxLayout( widget );
layout->setMargin( 0 );
m_display = new QTextEdit( widget );
m_display = new KTextEdit( widget );
QSizePolicy displaySizePolicy = m_display->sizePolicy();
displaySizePolicy.setVerticalStretch( 10 );
displaySizePolicy.setVerticalPolicy( QSizePolicy::MinimumExpanding );
......
......@@ -28,7 +28,7 @@
#include <KDialog>
class EquationEditorWidget;
class QTextEdit;
class KTextEdit;
/**
* Mini-calculator for calculating values of functions, etc.
......@@ -49,7 +49,7 @@ class Calculator : public KDialog
protected:
EquationEditorWidget* m_input;
QTextEdit *m_display;
KTextEdit* m_display;
QString m_displayText;
};
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment