Commit 6732e10d authored by Pino Toscano's avatar Pino Toscano

cmake: pass the minimum version (0.9.5) to macro_optional_find_package

parent e7366b2c
......@@ -18,10 +18,11 @@ macro_bool_to_01(CFITSIO_FOUND HAVE_CFITSIO_H)
macro_log_feature(CFITSIO_FOUND "libcfitsio0" "Support for the FITS (Flexible Image Transport System) data format in KStars." "http://indi.sf.net" FALSE "3.09" "")
# INDI is a Linux-specific addon
set(INDI_MINIMUM_VERSION 0.9.5)
IF(${CMAKE_SYSTEM_NAME} STREQUAL "Linux")
macro_optional_find_package(INDI)
macro_optional_find_package(INDI ${INDI_MINIMUM_VERSION})
macro_bool_to_01(INDI_FOUND HAVE_INDI_H)
macro_log_feature(INDI_FOUND "libindi" "Support for controlling astronomical devices with KStars." "http://www.indilib.org" FALSE "0.9.5" "")
macro_log_feature(INDI_FOUND "libindi" "Support for controlling astronomical devices with KStars." "http://www.indilib.org" FALSE "${INDI_MINIMUM_VERSION}" "")
ENDIF(${CMAKE_SYSTEM_NAME} STREQUAL "Linux")
macro_optional_find_package(WCSLIB)
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment