Commit c3546320 authored by Jasem Mutlaq's avatar Jasem Mutlaq

Make KStars depend on libindi v0.9.6

parent 947c4c5a
......@@ -62,13 +62,13 @@ else (INDI_INCLUDE_DIR AND INDI_DATA_DIR AND INDI_LIBRARIES AND INDI_DRIVER_LIBR
# Find pkg-config
FIND_PROGRAM(PKGCONFIG_EXECUTABLE NAMES pkg-config PATHS /usr/bin/ /usr/local/bin )
# query pkg-config asking for a libindi >= 0.9.5
EXEC_PROGRAM(${PKGCONFIG_EXECUTABLE} ARGS --atleast-version=0.9.5 libindi RETURN_VALUE _return_VALUE OUTPUT_VARIABLE _pkgconfigDevNull )
# query pkg-config asking for a libindi >= 0.9.6
EXEC_PROGRAM(${PKGCONFIG_EXECUTABLE} ARGS --atleast-version=0.9.6 libindi RETURN_VALUE _return_VALUE OUTPUT_VARIABLE _pkgconfigDevNull )
if(_return_VALUE STREQUAL "0")
set(INDI_FOUND TRUE)
else(_return_VALUE STREQUAL "0")
set(INDI_FOUND FALSE)
message(STATUS "Could NOT find libindi. pkg-config indicates that libindi >= 0.9.5 is not installed.")
message(STATUS "Could NOT find libindi. pkg-config indicates that libindi >= 0.9.6 is not installed.")
endif(_return_VALUE STREQUAL "0")
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment