Commit 9bf2f1ef authored by Sandro Andrade's avatar Sandro Andrade
Browse files

Remove use of QuickCompiler

It fails when current Qt version differs from version used when compiling:
"File was compiled ahead of time with an incompatible version of Qt and the original file cannot be found. Please recompile"
parent 558cbcc1
......@@ -41,8 +41,6 @@ find_package(Qt5 ${QT_MIN_VERSION} CONFIG REQUIRED COMPONENTS
Svg
)
find_package(Qt5 CONFIG QUIET OPTIONAL_COMPONENTS QuickCompiler)
IF(NOT ${CMAKE_SYSTEM_NAME} MATCHES "Android")
find_package(KF5 ${KF5_MIN_VERSION} REQUIRED COMPONENTS
CoreAddons
......
......@@ -6,11 +6,7 @@ set(minuet_SRCS
exercisecontroller.cpp
)
if (Qt5QuickCompiler_FOUND)
qtquick_compiler_add_resources(minuet_qml_SRCS qml.qrc)
else ()
qt5_add_resources(minuet_qml_SRCS qml.qrc)
endif()
qt5_add_resources(minuet_SRCS qml.qrc)
IF(NOT ${CMAKE_SYSTEM_NAME} MATCHES "Android")
set(minuet_ICONS_PNG
......@@ -44,7 +40,7 @@ IF(NOT ${CMAKE_SYSTEM_NAME} MATCHES "Android")
ecm_install_icons(ICONS ${minuet_ICONS_PNG} ${minuet_ICONS_SVG} DESTINATION ${ICON_INSTALL_DIR} THEME hicolor)
ENDIF(NOT ${CMAKE_SYSTEM_NAME} MATCHES "Android")
add_executable(minuet ${minuet_SRCS} ${minuet_qml_SRCS})
add_executable(minuet ${minuet_SRCS})
target_link_libraries(minuet
Qt5::Core
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment