Commit 4be6ce4e authored by Thomas Friedrichsmeier's avatar Thomas Friedrichsmeier
Browse files

Merge branch 'releases/0.7.0'

parents 587f7e1e dc359f41
......@@ -8,8 +8,12 @@ rkward (0.7.0b-1) unstable; urgency=low
Includes missing translation files in rkward-data
* Replace kdoctools-dev dependency with libkf5doctools-dev
closes: #895875
* Depend on r-api-3.5 when built against r-base-core >= 3.5.0
* Do not depend on r-api-3.4 when built against r-base-core < 3.4.0
* Remove explicit specification of C compiler
closes: #900591
-- Thomas Friedrichsmeier <thomas.friedrichsmeier@kdemail.net> Mon, 16 Apr 2018 20:00:00 +0100
-- Thomas Friedrichsmeier <thomas.friedrichsmeier@kdemail.net> Sat, 02 Jun 2018 09:00:00 +0100
rkward (0.7.0-1) unstable; urgency=low
* New upstream release
......
......@@ -20,11 +20,7 @@ BUILDDIR = $(CURDIR)/debian/build
override_dh_auto_configure:
mkdir -p $(BUILDDIR)
# Some installations of R need a specific version of the compiler(s)
# R CMD config provides info on which compiler to use
CC="`/usr/bin/R CMD config CC`" \
CXX="`/usr/bin/R CMD config CXX`" \
F77="`/usr/bin/R CMD config F77`" \
dh_auto_configure '--buildsystem=kf5' --parallel -- \
-DR_EXECUTABLE=/usr/bin/R/ \
-DR_LIBDIR=/usr/lib/R/site-library/ \
......@@ -48,9 +44,13 @@ override_dh_compress:
override_dh_shlibdeps:
dh_shlibdeps
# unfortunately, the r-base-core dependency can not be found by dh_shlibdeps, so we need to get at the version manually
# NOTE: This "if" is currently always true (see build-deps), but left here, for convenience, in case we get into trouble
# with binary incompatibility (esp. foward incompatibility) again, in the future.
@if [ "$(RMAJOR)" -eq "3" ] && [ "$(RMINOR)" -ge "0" ] ; then \
@if [ "$(RMAJOR)" -eq "3" ] && [ "$(RMINOR)" -ge "5" ] ; then \
echo "rvers=r-base-core (>= $(RVERS))" >> $(CURDIR)/debian/rkward.substvars ; \
echo "rapivers=r-api-3.5" >> $(CURDIR)/debian/rkward.substvars ; \
else \
if [ "$(RMAJOR)" -eq "3" ] && [ "$(RMINOR)" -ge "4" ] ; then \
echo "rvers=r-base-core (>= $(RVERS)), r-base-core (<< 3.5.0)" >> $(CURDIR)/debian/rkward.substvars ; \
echo "rapivers=r-api-3.4" >> $(CURDIR)/debian/rkward.substvars ; \
fi
else \
echo "rvers=r-base-core (>= $(RVERS)), r-base-core (<< 3.5.0)" >> $(CURDIR)/debian/rkward.substvars ; \
fi; fi; fi
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment