Commit c5325e2a authored by Thomas Friedrichsmeier's avatar Thomas Friedrichsmeier
Browse files

Merge branch 'master' into work/kateintegration

parents 21c839aa 9e24329f
......@@ -6,6 +6,7 @@ rkward/plugins/po/
# Generated from cmake
rkward/resource.ver
rkward/version.h
rkward/rbackend/rpackages/rkward/R/ver.R
# Log files from testing
tests/make_plugintests.txt
# Message templates and imported translations should not be in the repo
......
......@@ -22,7 +22,7 @@ INCLUDE(ECMMarkNonGuiExecutable)
INCLUDE(FeatureSummary)
FIND_PACKAGE(Qt5 5.2 CONFIG REQUIRED COMPONENTS Widgets Core Xml Network WebKitWidgets Script PrintSupport)
FIND_PACKAGE(KF5 5.2 REQUIRED COMPONENTS CoreAddons DocTools I18n XmlGui TextEditor WidgetsAddons WebKit Parts Config Notifications WindowSystem OPTIONAL_COMPONENTS Crash)
FIND_PACKAGE(KF5 5.4 REQUIRED COMPONENTS CoreAddons DocTools I18n XmlGui TextEditor WidgetsAddons WebKit Parts Config Notifications WindowSystem OPTIONAL_COMPONENTS Crash)
FIND_PACKAGE(Gettext REQUIRED)
# FindIntl in cmake is broken for MSVC on Windows, (and only included from 3.2.3 upwards).
......
This licence applies to files in rkward/icons/app-icon/lgpl
--
GNU LIBRARY GENERAL PUBLIC LICENSE
Version 2, June 1991
......
--- Version 0.7.1 - UNRELEASED
- Instead of installing rkward R packages at build time, install them at runtime, when needed TODO: Testing, document removal of -DR_LIBDIR for packagers
- Add new commandline option "--r-executable=auto" for auto-detection of R installation
- Fixed: Underscore (_) was not accepted in names of newly created data.frames
- <browser> element in save file mode gains checkbox to control overwriting of existing files
- Fixed: <browser> element could not be set to not required
- Fixed: max.print option was not saved, correctly, when set from RKWard settings
- Add command-line option --autoreuse to avoid shipping two separate .desktop files
- <select> elements in plugin dialogs can be set to accept only a single selection
- New R functions rk.capture.output() and and rk.end.capture.output()
- Allow to reference current script file in plugins TODO: Test this
- Add various live-preview options for R scripts, including a preview of R markdown rendering
- Make it possible to "link" to specific settings pages from the internal documentation
- Slighlty less confusing output in case a package is installed from require(), such as in many plugins
- Fixed: RKWard icon was missing for the "enhances RKWard" column in package installation dialog
- Fixed a layout issue in plugins using <stretch>-elements that would sometimes also render top-left aligned UI-elements unsuable.
- Remove a bit of unused empty space around the main area of plugin dialogs
- Expand root level objects (esp. data.frames) by default in plugin object lists. Add button to toggle back to collapsed.
- Allow Tab-key to advance to the next row of data in data editor
- Fix highlighting of "trailing" rows and columns in data editor
- Fixed: Loading existing workspace from startup dialog failed silently.
- Support handling of help:/ pages (e.g. RKWard plugins documentation) inside the RKWard help window, again.
- Do not attempt object name hinting behind empty quoted strings or spaces.
- rk.show.question() gains a parameter to allow setting a default button other than "yes"
- new function rk.askYesNo() combines the functionality of askYesNo() (R >= 3.5.0) with rk.show.question() and is the default option for askYesNo() calls
- Compile in ui definitions, instead of providing them as separate files
- Fix printing of strings with R 3.5.0 on Windows in the console
- Offer R_LIBS_USER, instead of ~/.rkward/library as standard library installation location
- Support R version placeholder (%v) in custom library locations.
- File browser tool window follows changes in current working directory (while showing current working directory)
- Show focus indication in highlighted item color (usually blue), instead of hardcoded red
- On Mac, do not attempt to start DBus, if it is already running
- Fix most compiler warnings
- File tool window gains button to switch to current working directory
- Fix a crash when closing a plugin dialog with an active plot preview
- Do not throw an error on objects that return non-numeric/non-scalar dim()
--- Version 0.7.0b - Apr-16-2018
- Fix failure to install translations
--- Version 0.7.0 - Apr-16-2018
- Fix crash with R 3.5.x due to use to STRING_PTR
- Double click on object in Workspace browser tries to open reference page, not object viewer, if the object is outside of .GlobalEnv
- Implement "split view" feature, allowing to partion the main window, and to hvae several views of the same files / data side-by-side
......
......@@ -3,7 +3,7 @@ Committing to the RKWard repository
This is a very short guideline, primarily for those who have KDE developer access, and are wondering whether, and how to commit to the RKWard repository, directly.
If you do not have KDE developer access, contact us on the mailing list (rkward-devel@kde.org), or submit patches via reviewboard (see below).
If you do not have KDE developer access, contact us on the mailing list (rkward-devel@kde.org), or submit patches via phabricator (see below).
Library dependencies
====================
......@@ -23,8 +23,6 @@ Branches and policies
* master:
Most development happens in master. For the time being master is always open for commits, although you are encouraged to develop more elaborate new features in a separate branch. Do try to keep this branch compilable and functional at all times (some rough edges are allowed, though). For more disruptive work, use a "work" branch (see below).
* frameworks:
The KF5 port of RKWard. This is the future master branch (it will be renamed to master, when the time has come). All commits to master get merged into this branch, but not vice-versa. For as long as this branch is _not_ yet master, the commit policy is somewhat more relaxed than master. As the port is stabilizing, you should still try to avoid fundamental breakage.
* releases/*
These branches are more restricted. In general you should:
* not add any new features (only fixes) to these
......@@ -34,6 +32,8 @@ Branches and policies
This will be updated for each new stable release, but _only_ for each new stable release. Meant to allow tracking released versions. In general, please don't commit / push anything, here, unless you are the release manager.
* work/*
For longer, experimental, or disruptive work, consider creating a branch named "work/feature_description". Do let us know, when the feature is merged (or discarded), and the branch can be removed.
* kde4:
The latest KDE4 based development version of RKWard. There may or may not be future bugfix releases for KDE4, but no active development is expected on this branch.
Testing
=======
......@@ -49,4 +49,4 @@ and after your changes. If in any doubt, ask on the mailing list rkward-devel@kd
Review
======
There is no strict policy on code reviews. It is never wrong to ask for review on git.reviewboard.kde.org, though. Always select group "rkward". It is also possible to create a "Differential" fo RKWArd in Phabriactor: https://phabricator.kde.org/differential/diff/create/ .
There is no strict policy on code reviews. It is never wrong to ask for review on Phabricator: https://phabricator.kde.org/differential/diff/create/ . Always select repository "RKward".
......@@ -34,8 +34,6 @@ In some cases you may want to set the following options:
-DR_EXECUTABLE
path to the R executable. You may want to set this, if you have multiple versions of R installed, or R is not in your path. Example: -DR_EXECUTABLE=/usr/bin/R
-DR_LIBDIR
directory where R packages should be installed. Generally, this option is only of interest to packagers.
-DR_HOME
R home directory. Almost certainly this option is not needed.
-DR_INCLUDEDIR
......@@ -46,6 +44,8 @@ In some cases you may want to set the following options:
-DUSE_BINARY_PACKAGES
Currently only interpreted on Mac OS: If RKWard should default to installing binary R packages (if available) use
-DUSE_BINARY_PACKAGE=1. Otherwise, RKWard will default to building R packages from source.
-DTRANSLATION_SRC_CIR
If you have imported translation source files (.po-files) to a separate directory, you can specify this, here.
Further generic options are listed on http://www.cmake.org/Wiki/CMake_Useful_Variables .
......
# DO NOT CHANGE THIS FILE MANUALLY!
# It will be overwritten by scripts/set_dist_version.sh
SET(RKVERSION_NUMBER 0.6.9z+0.7.0+devel1)
SET(RKVERSION_NUMBER 0.7.0z+0.7.1+devel2)
rkward (0.7.0-1) UNRELEASED; urgency=low
* New upstream release
* The divergently licenced qwinhost-files are no longer part of this release,
simplifying copyright
* Package now based on kf5-libraries, instead of KDE 4
closes: #531086
* Add dependency on r-api-3.4 to ease handling of future non-compatible changes in R
closes: #877283
* Use dh_auto_configure for basic setup
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Mon, 26 Mar 2018 11:00:00 +0100
rkward (0.6.5-1) unstable; urgency=low
* new upstream release
(unchanged with respect to ~rc1)
* fix debian/watch file
* always use build-time version of r-base-core as runtime dependency, even
if most builds would actually be backwards compatible
* switch to dh-based rules file. This also fixes missing separation between
arch-dependent and arch-independent build targets
* Make build really reproducible (fix for earlier attempt upstream)
closes: #783290
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Mon, 04 Apr 2016 11:00:00 +0100
rkward (0.6.5~rc1-1) unstable; urgency=low
* new upstream release
* split architecture independent files into new rkward-data package
* bump standards version to 3.9.7 (no changes needed)
* strip testing locale "x-test" from package
* add override for false-positive source-contains-prebuilt-javascript-object
lintian warnings
* make existing lintian overrides work with lintian 2.5.42
* Adjust copyright file to changed filenames in rkward/qwinhost
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Tue, 29 Mar 2016 11:00:00 +0100
rkward (0.6.4-1) unstable; urgency=low
* new upstream release
* add override for false-positive source-is-missing lintian warnings
* remove obsolete README.Debian file
* increase debhelper compatibility level to 9 (no changes needed)
* replace dh_clean -k with dh_prep
* remove legacy rules dealing with R versions prior to 3.0.0
* upstream has replaced KHTMLPart with QWebKit. As Qt4WebKit is scheduled for
removal, revert this change, here. Change to 3.0 (quilt) format for this.
* Make build reproducible (thanks to Philip Rinn)
closes: #783290
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Wed, 16 Dec 2015 10:30:00 +0100
rkward (0.6.3-1) unstable; urgency=low
* new upstream release
* Ajdust to move of homepage to rkward.kde.org, and vcs to git.kde.org
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Sat, 07 Mar 2015 13:30:00 +0100
rkward (0.6.2~rc1-2) unstable; urgency=low
* bump standards version to 3.9.6 (no changes needed)
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Fri, 17 Oct 2014 10:30:00 +0100
rkward (0.6.2~rc1-1) unstable; urgency=low
* new upstream release
* avoid duplicate cmake run during build
* upstream increased lowest supported R version to 2.8.0
* bump standards version to 3.9.4 (no changes needed)
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Thu, 16 Oct 2014 13:30:00 +0100
rkward (0.6.1-1) unstable; urgency=low
* upstream release 0.6.1-rc1 was made available as 0.6.1 without changes
* new upload to build against R 3.0.0 on most architectures
* when built against r-base-core >= 3.0.0, depend on r-base-core <= 3.0.0
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Thu, 07 May 2013 12:30:00 +0100
rkward (0.6.1~rc1-1) unstable; urgency=low
* new upstream release
* re-add Vcs-Browser field
* fix year in changelog (previous upload had 2012 instead of 2013)
* add runtime dependency on r-base-core < 3.0.0 unless compiled with >= 3.0.0
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Thu, 28 Mar 2013 09:30:00 +0100
rkward (0.6.0-3) unstable; urgency=low
* correctly treat -pre releases in debian/watch (thanks to Bart Martens)
* remove obsolete DM-Upload-Allowed field
* update Vcs-Svn field to changed repository URL
* remove Vcs-Browser field, as there is no useful repository browser, ATM
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Tue, 15 Jan 2012 12:30:00 +0100
rkward (0.6.0-2) unstable; urgency=low
* make sure to include CPPFLAGS and LDFLAGS in call to cmake
* correct path to qwinhost files in debian/copyright
* correct syntax in debian/copyright (thanks to Laszlo Kajan)
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Sat, 24 Nov 2012 14:15:00 +0200
rkward (0.6.0-1) unstable; urgency=low
* new upstream release
* remove support for building on Ubuntu hardy
* more accurate copyright file
closes: #689982
* bump standards version to 3.9.4 (no changes needed)
* Add Vcs-Browser and Vcs-Svn fields
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Wed, 24 Oct 2012 15:30:00 +0200
rkward (0.5.7-2) unstable; urgency=low
* new upload to force rebuild against R 2.14.0~x on i386
closes: #646047 (failure to load rkward package)
* add dependency on r-base-core < 2.14 if built against R < 2.14.0
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Tue, 25 Oct 2011 14:30:00 +0200
rkward (0.5.7-1) unstable; urgency=low
* new upstream release
* provide build-arch and build-indep targets
* include buildflags as instructed by the dpkg developers
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Sun, 23 Oct 2011 15:30:00 +0200
rkward (0.5.6-1) unstable; urgency=low
* new upstream release
* remove empty directory removal rkwardtests/inst. Now fixed upstream.
* remove man page links to rkward.bin and rkward.rbackend. These
auxiliary binaries are no longer installed in the system path.
* remove debian man page. Man page is now supplied upstream.
* drop explicit dependency on libphonon-dev.
* fix lintian warning "description-synopsis-starts-with-article"
* bump standards version to 3.9.2 (no changes needed)
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Tue, 30 May 2011 15:30:00 +0200
rkward (0.5.5-2) unstable; urgency=low
* Remove empty directory rkwardtests/inst
fixes FTBFS with (the current alpha of) R 2.13.0
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Tue, 20 Mar 2011 14:30:00 +0200
rkward (0.5.5-1) unstable; urgency=low
* new upstream release
* add man-page link for new binary rkward.rbackend
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Tue, 15 Mar 2011 14:30:00 +0200
rkward (0.5.4-1) unstable; urgency=low
* new upstream release
* bump standards version to 3.9.1 (no changes needed)
* no more need to remove svncopy.sh-script in rules
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Mon, 04 Oct 2010 14:30:00 +0200
rkward (0.5.3-2) unstable; urgency=low
* correct usage of hyphens vs. minus signs in the man page
* correct the watch file
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Fri, 07 May 2010 14:30:00 +0200
rkward (0.5.3-1) unstable; urgency=low
* new upstream release
closes: #556321 (failed to link against thread-library, explicitly)
* add watch file (thanks to Julien Lavergne and Scott Howard)
closes: #569114
* remove svncopy.sh-script included in upstream release tarball by accident
* remove obsolete runtime dependency on php5-cli
* add dependency on ${misc:Depends} as recommended by debhelper
* bump standards version to 3.8.4 (no changes needed)
* add Homepage field
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Fri, 30 Apr 2010 14:30:00 +0200
rkward (0.5.2-1) unstable; urgency=low
* new upstream release
closes: #551306 (added support for the new dynamic help system)
* Add "DM-Upload-Allowed: yes" in control
* bump standards version to 3.8.3 (no changes needed)
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Mon, 26 Oct 2009 14:30:00 +0200
rkward (0.5.1-2) unstable; urgency=low
* drop alternative depend on php4-cli as this is no longer part of any
current debian based distribution
* more accurate detection of patch-needing Ubuntu
Hardy systems (thanks to Meik Michalke)
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Tue, 18 Aug 2009 14:30:00 +0200
rkward (0.5.1-1) unstable; urgency=low
* new upstream release
* bump standards version to 3.8.2 (no changes needed)
* dropped notice on development status from description
* added notice on differing copyright and additional
LGPL licence of some files
* better version detection (thanks to Meik Michalke)
* added conditional patch to support Ubuntu hardy (thanks to Meik Michalke)
* decrease debhelper compat level to 6, in order to support Ubuntu hardy
* revert to using dh_clean -k in order to comply with compat level 6
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Tue, 04 Aug 2009 14:30:00 +0200
rkward (0.5.0d-3) unstable; urgency=low
* build-depend on libx11-dev
closes: #529024
* use dh_prep instead of deprecated dh_clean -k
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Mon, 19 May 2009 14:30:00 +0200
rkward (0.5.0d-2) unstable; urgency=low
* bumped standards version to 3.8.1
* increased debhelper compat-level to 7
* upload to unstable (repeat closes because 0.5.0d-1 was not uploaded)
closes: #520969
closes: #491110
closes: #501649
closes: #527649 (included missing Rdevices.h; actually fixed in 0.5.0c)
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Sun, 11 May 2009 14:30:00 +0200
rkward (0.5.0d-1) unstable; urgency=low
* new upstream release
* upload to unstable (repeat closes because 0.5.0c-1 was not uploaded)
closes: #520969
closes: #491110
closes: #501649
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Sun, 10 May 2009 21:30:00 +0200
rkward (0.5.0c-1) experimental; urgency=low
* new upstream release
closes: #520969 (added support for R 2.9.0)
* query kde4-config to set the correct installation paths
closes: #491110 (resource files were not found)
closes: #501649 (plugin files were not found)
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Wed, 30 Mar 2009 20:30:00 +0200
rkward (0.5.0b-1) unstable; urgency=low
* new upstream release
closes: #475175
closes: #463348
closes: #475982
closes: #455709
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Sun, 20 Apr 2008 21:30:00 +0200
rkward (0.5.0a-1) experimental; urgency=low
* new upstream release
* remove some obsolete comments in rules
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Wed, 23 Jan 2008 16:30:00 +0200
rkward (0.5.0-1) experimental; urgency=low
* new upstream release
closes: #455709
* adjusted to build with KDE4 libraries / CMake
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Mon, 21 Jan 2008 20:30:00 +0200
rkward (0.4.9a-1) unstable; urgency=low
* new upstream release
closes: #475175
closes: #463348
closes: #475982
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Sun, 20 Apr 2008 21:30:00 +0200
rkward (0.4.9-2) unstable; urgency=low
* remove --ignore-missing-info parameter again (dpkg-shlibdeps 1.14.12
does not need it, anymore)
* when uploaded to main archive, this
closes: #460745
* bumped standards to 3.7.3 (no changes necessary)
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Wed, 16 Jan 2008 17:30:00 +0200
rkward (0.4.9-1) unstable; urgency=low
* new upstream release
* add --ignore-missing-info paramater to dpkg-shlibdeps, as libR.so will not be found
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Mon, 14 Jan 2008 20:30:00 +0200
rkward (0.4.8a-2) unstable; urgency=low
* quote the R CMD config calls, as they may also contain compiler arguments
(thanks to Meik Michalke for a patch)
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Thu, 14 Nov 2007 13:30:00 +0200
rkward (0.4.8a-1) unstable; urgency=low
* new upstream release
* document --disable-stack-check and --debugger options in the manual page
* use the compilers specified by R CMD config
closes: #450618
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Sun, 11 Nov 2007 13:30:00 +0200
rkward (0.4.8-1) unstable; urgency=low
* new upstream release
closes: #417519
* adjust rkward.menu to new naming policy
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Wed, 03 Oct 2007 13:30:00 +0200
rkward (0.4.7a-2) unstable; urgency=low
* force gcc 4.2 to match r-base-core
closes: #432377
* merge upstream fix for R 2.6
closes: #442059
* changed distclean rule in debian/rules to only ignore missing Makefiles
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Fri, 14 Sep 2007 13:30:00 +0200
rkward (0.4.7a-1) unstable; urgency=low
* new upstream release
closes: #422541
* the code to generate the correct r-base-core dependencies should now be POSIX shell compliant
* remove unused (and uncommented) dh_* scripts from rules
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Mon, 07 May 2007 13:30:00 +0200
rkward (0.4.7-2) unstable; urgency=low
* explicitely create installation directory for rkward R package
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Wed, 11 Apr 2007 15:30:00 +0200
rkward (0.4.7-1) unstable; urgency=low
* new upstream release
closes: #415561 (filename completion)
closes: #418686 (failure to work with R 2.5.0)
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Wed, 11 Apr 2007 13:30:00 +0200
rkward (0.4.6-1) unstable; urgency=low
* new upstream release
* update r-base-core dependencies
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Thu, 15 Feb 2007 19:30:00 +0200
rkward (0.4.5-1) unstable; urgency=low
* new upstream release
* provide entry in debian menu (Apps/Math)
closes: #405376
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Sun, 21 Jan 2007 19:00:00 +0200
rkward (0.4.2-3) unstable; urgency=low
* this version is not meant to be uploaded to the main archives!
* fix compilation on sarge
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Wed, 13 Dec 2006 17:30:00 +0200
rkward (0.4.2-2) unstable; urgency=low
* migrate to unstable
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Wed, 06 Dec 2006 20:00:00 +0200
rkward (0.4.2-1) experimental; urgency=low
* new upstream release
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Tue, 04 Dec 2006 16:45:00 +0200
rkward (0.4.1-1) unstable; urgency=low
* new upstream release
* depend on either php4-cli or php5-cli
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Mon, 06 Nov 2006 16:30:00 +0200
rkward (0.4.0-2) unstable; urgency=low
* fix automatic build on 64bit architectures
closes: #394112
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Fri, 20 Oct 2006 14:00:00 +0200
rkward (0.4.0-1) unstable; urgency=low
* new upstream release
* remove obsoleted workaround for installation of rkward R package
* cope with switch from CVS to SVN
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Tue, 17 Oct 2006 14:40:00 +0200
rkward (0.3.7-1) unstable; urgency=low
* new upstream release
* use confiure option --with-r-libdir to make sure the rkward R package is installed in /usr/lib/R/site-library/
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Sun, 17 Sep 2006 16:40:00 +0200
rkward (0.3.6-4) unstable; urgency=low
* fix automatic build on alpha machines
patch provided by Martin Michlmayr <tbm@cyrius.com>
closes: #374005
* bumbed to standards 3.7.2
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Sun, 18 Jun 2006 16:25:00 +0200
rkward (0.3.6-3) unstable; urgency=low
* first version to be uploaded to debian
closes: #333392
* Added Homepage to control file (changed by R.M.Rutschmann <rudi@debian.org>)
* fix detection of r-base-core dependency when compiled with r-base-core >= 2.3.0
* clean up rules somewhat
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Tue, 25 Apr 2006 12:45:00 +0200
rkward (0.3.6-2) unstable; urgency=low
* link manpage directly in installation instead of debian-dir
* use --show-format instead of -f in call to dpkg-query (to work on stable)
* delete any debian/CVS subdir included by accident during clean
* add newline to copyright file
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Mon, 24 Apr 2006 14:45:00 +0200
rkward (0.3.6-1) unstable; urgency=low
* new upstream release
* clean up manpage
* debian dir is not longer included in upstream; create non-native package
* create symlink rkward.bin.1 to rkward.1 and remove linitian expection (no man page)
* use ${shlibs:Depends} for runtime dependencies
* make sure to require correct version of r-base-core
* specify --with-r-home in ./configure, in case there is more than one version of R installed
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Sun, 23 Apr 2006 19:45:00 +0200
rkward (0.3.5) unstable; urgency=low
* new upstream release
* add lintian exception for rkward.bin (no man page)
* remove call to build-help.pl during postinst postrm
* use --disable-rpath in ./configure
* remove /usr/sbin from dirs
* use standards version 3.6.2
* add man page
* remove redundant build-dependency on libqt3-mt-dev
* break long lines in description
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Sun, 16 Apr 2006 15:45:00 +0200
rkward (0.3.4) unstable; urgency=low
* new upstream release
* debian directory is now included in official release
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Tue, 08 Nov 2005 16:00:33 +0200
rkward (0.3.3) unstable; urgency=low
* new upstream release
* Adjusted depends for R (2.1.0)
* added run-time depend for libstdc++6
* correct path for KDE help files
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Mon, 10 Oct 2005 11:20:33 +0200
rkward (0.3.2) unstable; urgency=low
* new upstream release
* Initial Release.
* removing r.xml highlighting definition in order to avoid conflict with verison shipped with katepart
-- Thomas Friedrichsmeier <tfry@users.sourceforge.net> Tue, 26 Apr 2005 00:00:33 +0200
Source: rkward
Section: math
Priority: optional
Maintainer: Thomas Friedrichsmeier <tfry@users.sourceforge.net>
Build-Depends: cmake,
extra-cmake-modules,
pkg-kde-tools | pkg-kf5-tools,