Commit c734d400 authored by Allen Winter's avatar Allen Winter

CMakeLists.txt - increase minimum libical version to 3.0

parent 09a42cf4
......@@ -47,13 +47,11 @@ ecm_setup_version(PROJECT VARIABLE_PREFIX KCALENDARCORE
########### Find packages ###########
find_package(Qt5 ${REQUIRED_QT_VERSION} CONFIG REQUIRED Core Gui)
set(LibIcal_MIN_VERSION "2.0")
set(LibIcal_MIN_VERSION "3.0")
find_package(LibIcal ${LibIcal_MIN_VERSION})
set_package_properties(LibIcal PROPERTIES TYPE REQUIRED)
if(LibIcal_VERSION VERSION_GREATER "2.98")
set(HAVE_ICAL_3 TRUE)
add_definitions(-DUSE_ICAL_3)
endif()
set(HAVE_ICAL_3 TRUE)
add_definitions(-DUSE_ICAL_3)
########### CMake Config Files ###########
set(CMAKECONFIG_INSTALL_DIR "${KDE_INSTALL_CMAKEPACKAGEDIR}/KF5CalendarCore")
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment