Commit 9bd041a7 authored by Laurent Montel's avatar Laurent Montel 😁
Browse files

Use QT_REQUIRED_VERSION

parent eb2e90f0
......@@ -3,6 +3,7 @@ cmake_minimum_required(VERSION 2.8.12)
project(KContacts)
# ECM setup
set(QT_REQUIRED_VERSION "5.5.0")
set(KF5_VERSION "5.25.0")
find_package(ECM ${KF5_VERSION} CONFIG REQUIRED)
set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} ${KContacts_SOURCE_DIR}/cmake)
......@@ -29,7 +30,7 @@ ecm_setup_version(${KCONTACTS_LIB_VERSION} VARIABLE_PREFIX KContacts
)
########### Find packages ###########
find_package(Qt5 5.4 REQUIRED COMPONENTS DBus Gui)
find_package(Qt5 ${QT_REQUIRED_VERSION} REQUIRED COMPONENTS DBus Gui)
find_package(KF5 ${KF5_VERSION} REQUIRED COMPONENTS CoreAddons I18n Config Codecs)
########### Targets ###########
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment