Commit bfa0ba12 authored by Laurent Montel's avatar Laurent Montel 😁
Browse files

We depend against 5.64

parent 112a25b2
......@@ -21,7 +21,6 @@
#include "protocols/carddavprotocol_p.h"
#include "protocols/groupdavprotocol_p.h"
#include <kio_version.h>
#include <KIO/DavJob>
#include "libkdav_debug.h"
......@@ -44,11 +43,6 @@ KIO::DavJob *DavManager::createPropFindJob(const QUrl &url, const QDomDocument &
{
KIO::DavJob *job = KIO::davPropFind(url, document, depth, KIO::HideProgressInfo | KIO::DefaultFlags);
#if KIO_VERSION < QT_VERSION_CHECK(5, 63, 0)
// workaround needed, Depth: header doesn't seem to be correctly added
const QString header = QLatin1String("Content-Type: text/xml\r\nDepth: ") + depth;
job->addMetaData(QStringLiteral("customHTTPHeader"), header);
#endif
job->addMetaData(QStringLiteral("cookies"), QStringLiteral("none"));
job->addMetaData(QStringLiteral("no-auth-prompt"), QStringLiteral("true"));
job->setProperty("davDepth", QVariant::fromValue(depth));
......@@ -60,11 +54,6 @@ KIO::DavJob *DavManager::createReportJob(const QUrl &url, const QDomDocument &do
{
KIO::DavJob *job = KIO::davReport(url, document.toString(), depth, KIO::HideProgressInfo | KIO::DefaultFlags);
#if KIO_VERSION < QT_VERSION_CHECK(5, 63, 0)
// workaround needed, Depth: header doesn't seem to be correctly added
const QString header = QLatin1String("Content-Type: text/xml\r\nDepth: ") + depth;
job->addMetaData(QStringLiteral("customHTTPHeader"), header);
#endif
job->addMetaData(QStringLiteral("cookies"), QStringLiteral("none"));
job->addMetaData(QStringLiteral("no-auth-prompt"), QStringLiteral("true"));
job->setProperty("davDepth", QVariant::fromValue(depth));
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment