Commit 425b8340 authored by Frederik Schwarzer's avatar Frederik Schwarzer
Browse files

Use KCrash.

parent 1a8829b9
......@@ -2,24 +2,27 @@ project(kdiamond)
cmake_minimum_required (VERSION 2.8.12 FATAL_ERROR)
set (QT_MIN_VERSION "5.3.0")
set (KF5_MIN_VERSION "5.15.0")
find_package(ECM 1.7.0 REQUIRED CONFIG)
set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR})
find_package(Qt5 ${QT_MIN_VERSION} REQUIRED NO_MODULE COMPONENTS Widgets )
find_package(KF5 REQUIRED COMPONENTS
CoreAddons
Config
find_package(KF5 ${KF5_MIN_VERSION} REQUIRED COMPONENTS
CoreAddons
Config
Crash
DBusAddons
DocTools
WidgetsAddons
Config
I18n
ConfigWidgets
WidgetsAddons
Config
I18n
ConfigWidgets
XmlGui
Notifications
NotifyConfig)
NotifyConfig
)
find_package(KF5KDEGames 4.9.0 REQUIRED)
include(FeatureSummary)
......
......@@ -17,7 +17,15 @@ file(GLOB ICONS_SRCS "pics/*-apps-kdiamond.png")
ecm_add_app_icon(kdiamond_SRCS ICONS ${ICONS_SRCS})
add_executable(kdiamond ${kdiamond_SRCS})
target_link_libraries(kdiamond KF5KDEGames KF5::NotifyConfig KF5::I18n KF5::XmlGui KF5::Notifications KF5::DBusAddons)
target_link_libraries(kdiamond
KF5KDEGames
KF5::NotifyConfig
KF5::I18n
KF5::XmlGui
KF5::Notifications
KF5::DBusAddons
KF5::Crash
)
install(TARGETS kdiamond ${KDE_INSTALL_TARGETS_DEFAULT_ARGS})
install(FILES kdiamond.knsrc DESTINATION ${KDE_INSTALL_CONFDIR})
......
......@@ -22,6 +22,7 @@
#include <ctime>
#include <KAboutData>
#include <KCrash>
#include <KLocalizedString>
......@@ -54,6 +55,7 @@ int main(int argc, char **argv)
about.addCredit(i18n("Jeffrey Kelling"), i18n("Technical consultant"), QStringLiteral("kelling.jeffrey@ages-skripte.org"));
QCommandLineParser parser;
KAboutData::setApplicationData(about);
KCrash::initialize();
parser.addVersionOption();
parser.addHelpOption();
about.setupCommandLine(&parser);
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment