Commit 260668d3 authored by Laurent Montel's avatar Laurent Montel
Browse files

Use ECMDeprecationSettings

parent 4abae49a
Pipeline #281078 passed with stage
in 1 minute and 49 seconds
......@@ -13,7 +13,7 @@ set(KIGO_VERSION "${KIGO_BASE_VERSION}.${RELEASE_SERVICE_COMPACT_VERSION}")
project(kigo VERSION ${KIGO_VERSION})
set (QT_MIN_VERSION "5.15.2")
set (KF5_MIN_VERSION "5.90.0")
set (KF5_MIN_VERSION "5.92.0")
find_package(ECM ${KF5_MIN_VERSION} REQUIRED CONFIG)
set(CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/cmake ${ECM_MODULE_PATH})
......@@ -27,6 +27,7 @@ include(ECMInstallIcons)
include(ECMQtDeclareLoggingCategory)
include(ECMSetupVersion)
include(FeatureSummary)
include(ECMDeprecationSettings)
find_package(Qt${QT_MAJOR_VERSION} ${QT_MIN_VERSION} REQUIRED NO_MODULE COMPONENTS Widgets Svg)
......@@ -54,14 +55,13 @@ set_package_properties(GNUGo PROPERTIES
TYPE RUNTIME
)
add_definitions(
-DQT_DISABLE_DEPRECATED_BEFORE=0x050F00
-DQT_DEPRECATED_WARNINGS_SINCE=0x060000
-DKF_DISABLE_DEPRECATED_BEFORE_AND_AT=0x055800
-DKNEWSTUFF_DISABLE_DEPRECATED_BEFORE_AND_AT=0x054F00 # KNS3::DownloadDialog
-DKF_DEPRECATED_WARNINGS_SINCE=0x060000
ecm_set_disabled_deprecation_versions(
QT 5.15.2
KF 5.101
KDEGAMES 7.3
)
# added by KDE_COMPILERSETTINGS_LEVEL 5.85
remove_definitions(
-DQT_NO_CAST_FROM_ASCII
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment