Commit 0c5ebf9a authored by Laurent Montel's avatar Laurent Montel 😁

Revert "It's already done in kaboutdata"

Revert it as maintainer wants to compile on ubuntu 16.04...
I exclude kiriki from my list of apps that I will touch in the future

This reverts commit 95f256a7.
parent 60ab0959
project(kiriki)
cmake_minimum_required (VERSION 2.8.12 FATAL_ERROR)
set (QT_MIN_VERSION "5.7.0")
set (KF5_MIN_VERSION "5.30.0")
set (QT_MIN_VERSION "5.3.0")
set (KF5_MIN_VERSION "5.15.0")
find_package(ECM ${KF5_MIN_VERSION} REQUIRED CONFIG)
find_package(ECM 1.7.0 REQUIRED CONFIG)
set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR})
find_package(Qt5 ${QT_MIN_VERSION} REQUIRED NO_MODULE COMPONENTS Widgets PrintSupport)
......
......@@ -27,6 +27,8 @@ int main(int argc, char *argv[])
QCommandLineParser parser;
KAboutData::setApplicationData(about);
KCrash::initialize();
parser.addVersionOption();
parser.addHelpOption();
about.setupCommandLine(&parser);
parser.process(app);
about.processCommandLine(&parser);
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment