Commit 3c4068a3 authored by Friedrich W. H. Kossebau's avatar Friedrich W. H. Kossebau
Browse files

Enable warning for deprecated KF API up to 6.0

GIT_SILENT
parent 233ab2e3
...@@ -31,11 +31,12 @@ include(KDECompilerSettings NO_POLICY_SCOPE) ...@@ -31,11 +31,12 @@ include(KDECompilerSettings NO_POLICY_SCOPE)
include(KDECMakeSettings) include(KDECMakeSettings)
include(ECMQtDeclareLoggingCategory) include(ECMQtDeclareLoggingCategory)
add_definitions(-DQT_USE_FAST_OPERATOR_PLUS) add_definitions(
add_definitions(-DQT_NO_URL_CAST_FROM_STRING) -DQT_USE_FAST_OPERATOR_PLUS
if (EXISTS "${CMAKE_SOURCE_DIR}/.git") -DQT_NO_URL_CAST_FROM_STRING
add_definitions(-DKF_DISABLE_DEPRECATED_BEFORE_AND_AT=0x054400) -DKF_DISABLE_DEPRECATED_BEFORE_AND_AT=0x054400
endif() -DKF_DEPRECATED_WARNINGS_SINCE=0x060000
)
add_subdirectory(pics) add_subdirectory(pics)
add_subdirectory(doc) add_subdirectory(doc)
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment