Commit 5f65393f authored by Alexander Lohnau's avatar Alexander Lohnau 💬

Fix KNS deprecations

parent 721cfb52
......@@ -6,7 +6,7 @@ set(CMAKE_CXX_STANDARD_REQUIRED ON)
set(CMAKE_CXX_EXTENSIONS OFF)
set (QT_MIN_VERSION "5.7.0")
set (KF5_MIN_VERSION "5.30.0")
set (KF5_MIN_VERSION "5.57.0")
find_package(ECM ${KF5_MIN_VERSION} REQUIRED CONFIG)
......
......@@ -92,6 +92,6 @@ install(TARGETS knights ${KDE_INSTALL_TARGETS_DEFAULT_ARGS} )
install( PROGRAMS org.kde.knights.desktop DESTINATION ${KDE_INSTALL_APPDIR} )
install( FILES knights.kcfg DESTINATION ${KCFG_INSTALL_DIR} )
install( FILES knightsui.rc DESTINATION ${KDE_INSTALL_KXMLGUI5DIR}/knights )
install( FILES knights.knsrc DESTINATION ${KDE_INSTALL_CONFDIR} )
install( FILES knights.knsrc DESTINATION ${KDE_INSTALL_DATADIR}/knsrcfiles )
install( FILES org.kde.Knights.xml DESTINATION ${DBUS_INTERFACES_INSTALL_DIR} )
install( FILES org.kde.knights.appdata.xml DESTINATION ${KDE_INSTALL_METAINFODIR} )
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment