Drop unused dependencies

REVIEW: 127562
parent 3f692aa1
......@@ -7,29 +7,24 @@ set (KF5_MIN_VERSION "5.15.0")
find_package(ECM 1.7.0 REQUIRED CONFIG)
set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR})
find_package(Qt5 ${QT_MIN_VERSION} REQUIRED NO_MODULE COMPONENTS Widgets Qml Quick QuickWidgets Svg Test)
find_package(Qt5 ${QT_MIN_VERSION} REQUIRED NO_MODULE COMPONENTS Widgets Svg)
find_package(KF5 ${KF5_MIN_VERSION} REQUIRED COMPONENTS
Completion
Config
ConfigWidgets
CoreAddons
Crash
DBusAddons
GuiAddons
I18n
ItemModels
KDELibs4Support
KIO
NewStuff
NotifyConfig
TextWidgets
WidgetsAddons
WindowSystem
XmlGui
)
find_package(KF5KDEGames 4.9.0 REQUIRED)
find_package(Phonon4Qt5 CONFIG REQUIRED)
find_package(KF5DocTools ${KF5_MIN_VERSION})
include_directories(BEFORE ${PHONON_INCLUDES})
find_package(KF5KDEGames 4.9.0 REQUIRED)
include(FeatureSummary)
include(ECMAddAppIcon)
......@@ -42,7 +37,9 @@ add_definitions(-DQT_USE_FAST_CONCATENATION -DQT_USE_FAST_OPERATOR_PLUS)
add_subdirectory(pics)
add_subdirectory(themes)
add_subdirectory(doc)
if (KF5DocTools_FOUND)
add_subdirectory(doc)
endif()
########### next target ###############
......@@ -76,7 +73,6 @@ target_link_libraries(ksnakeduel
KF5::GuiAddons
KF5::I18n
KF5::KDELibs4Support
KF5::NotifyConfig
KF5KDEGames
KF5KDEGamesPrivate
)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment