Commit 884b1313 authored by Friedrich W. H. Kossebau's avatar Friedrich W. H. Kossebau
Browse files

Bump min CMake/Qt/KF deps to 3.16/5.15/5.85

parent 4e7bbf7f
cmake_minimum_required (VERSION 3.5 FATAL_ERROR)
cmake_minimum_required (VERSION 3.16 FATAL_ERROR)
set(KDEGAMES_VERSION 7.3.0)
set(KDEGAMES_SOVERSION 7)
project(libkdegames)
set (QT_MIN_VERSION "5.12.0")
set (KF_MIN_VERSION "5.68.0")
set (QT_MIN_VERSION "5.15.0")
set (KF_MIN_VERSION "5.85.0")
find_package(ECM ${KF_MIN_VERSION} REQUIRED NO_MODULE)
set(CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules ${ECM_MODULE_PATH})
......@@ -81,19 +81,11 @@ set(KGAUDIO_BACKEND_OPENAL TRUE) # for configure_file() below
add_definitions(-DTRANSLATION_DOMAIN="libkdegames5")
add_definitions(
-DQT_DEPRECATED_WARNINGS
-DQT_DISABLE_DEPRECATED_BEFORE=0x050900
-DQT_DEPRECATED_WARNINGS_SINCE=0x060000
-DQT_NO_FOREACH
-DQT_NO_KEYWORDS
-DQT_NO_URL_CAST_FROM_STRING
-DQT_NO_CAST_FROM_ASCII
-DQT_NO_CAST_TO_ASCII
-DQT_NO_CAST_FROM_BYTEARRAY
-DQT_STRICT_ITERATORS
-DQT_USE_QSTRINGBUILDER
-DQT_NO_NARROWING_CONVERSIONS_IN_CONNECT
-DKF_DISABLE_DEPRECATED_BEFORE_AND_AT=0x052e00
-DKF_DISABLE_DEPRECATED_BEFORE_AND_AT=0x055400
-DKCOREADDONS_DISABLE_DEPRECATED_BEFORE_AND_AT=0x054900 # KRandomSequence, cannot be removed
-DKNEWSTUFF_DISABLE_DEPRECATED_BEFORE_AND_AT=0x054F00 # KNS3::DownloadDialog -> needs porting
-DKF_DEPRECATED_WARNINGS_SINCE=0x060000
)
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment