Commit 50b26ca4 authored by Andreas Sturmlechner's avatar Andreas Sturmlechner
Browse files

Drop use of DETECT_LIBMEDIAWIKI

parent a723de2f
......@@ -45,6 +45,7 @@ set(CMAKE_MIN_VERSION "3.0.0")
set(KF5_MIN_VERSION "5.18.0")
set(QT_MIN_VERSION "5.6.0")
set(KIPI_MIN_VERSION "5.0.0")
set(MEDIAWIKI_MIN_VERSION "5.0.0")
cmake_minimum_required(VERSION ${CMAKE_MIN_VERSION})
############## ECM setup ######################
......@@ -158,7 +159,7 @@ message(STATUS "libkipi SO version : ${KIPI_LIB_SO_CUR_VERSION}")
# -- Optional dependencies detection required by some plugins -------------------------------------
DETECT_LIBMEDIAWIKI(5.0.0) # For Mediawiki.
find_package(KF5MediaWiki ${MEDIAWIKI_MIN_VERSION})
DETECT_LIBKVKONTAKTE(4.70.0) # For VKontakte.
# ==================================================================================================
......
......@@ -9,8 +9,6 @@ subdirs(icons)
add_definitions(-DTRANSLATION_DOMAIN=\"kipiplugin_mediawiki\")
include_directories(${LIBMEDIAWIKI_INCLUDES})
set(kipiplugin_wikimedia_PART_SRCS
plugin_wikimedia.cpp
wmwidget.cpp
......@@ -27,7 +25,7 @@ target_link_libraries(kipiplugin_wikimedia
KF5kipiplugins
${LIBMEDIAWIKI_LIBRARIES}
KF5::MediaWiki
)
configure_file(kipiplugin_wikimedia.desktop.cmake.in ${CMAKE_CURRENT_BINARY_DIR}/kipiplugin_wikimedia.desktop)
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment