Commit 3a215fac authored by Marius Pa's avatar Marius Pa
Browse files

CMakeLists.txt cmake_minimum_required should be first

https://cmake.org/cmake/help/latest/command/cmake_minimum_required.html :
"Note Call the cmake_minimum_required() command at the beginning of the
top-level CMakeLists.txt file even before calling the project() command.
It is important to establish version and policy settings before invoking
other commands whose behavior they may affect. See also policy CMP0000."
parent a131658e
Pipeline #247969 passed with stage
in 1 minute and 10 seconds
......@@ -4,13 +4,12 @@
# SPDX-License-Identifier: BSD-3-Clause
#
set(CMAKE_MIN_VERSION "3.16.0")
cmake_minimum_required(VERSION 3.16)
set(ECM_MIN_VERSION "5.90.0")
set(QT_MIN_VERSION "5.15.0")
set(EXIV2_MIN_VERSION "0.25")
cmake_minimum_required(VERSION ${CMAKE_MIN_VERSION})
project(libkexiv2 VERSION "5.0.0")
set(CMAKE_CXX_STANDARD 14) # exiv is not compatible with C++ > 14 yet
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment