Commit 65ca6b18 authored by Ömer Fadıl Usta's avatar Ömer Fadıl Usta 😊
Browse files

Sync QT_MIN_VERSION with KF's REQUIRED_QT_VERSION

In KF we already looking for 5.15.2
and looking something lower than that
is a bit meaningless
parent 800eed25
Pipeline #235549 passed with stage
in 1 minute and 15 seconds
......@@ -41,7 +41,7 @@ ecm_setup_version(
)
# Dependencies
set(REQUIRED_QT_VERSION "5.15.0")
set(REQUIRED_QT_VERSION "5.15.2")
# Required Qt5 components to build this framework
find_package(Qt${QT_MAJOR_VERSION} ${REQUIRED_QT_VERSION} NO_MODULE REQUIRED Core Widgets)
......@@ -80,7 +80,7 @@ add_definitions(
-DQT_STRICT_ITERATORS
)
add_definitions(
-DQT_DISABLE_DEPRECATED_BEFORE=0x050F00
-DQT_DISABLE_DEPRECATED_BEFORE=0x050F02
-DQT_DEPRECATED_WARNINGS_SINCE=0x060000
-DKF_DISABLE_DEPRECATED_BEFORE_AND_AT=0x055800
-DKF_DEPRECATED_WARNINGS_SINCE=0x060000
......
......@@ -17,7 +17,7 @@ The library documentation is available on header files.
## Dependencies
- CMake >= 3.16.0 https://cmake.org
- Qt >= 5.15.0 https://qt.io
- Qt >= 5.15.2 https://qt.io
- KDE Frameworks >= 5.90.0 https://www.kde.org
- KSaneCore from same KDE Gear https://invent.kde.org/libraries/ksanecore
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment