Commit c4e33d0e authored by Nicolas Fella's avatar Nicolas Fella
Browse files

Make dependency on KI18n and KTextWidgets explicit

They are already pulled in by KParts, but we better not rely on that
parent 6a6b6ca3
Pipeline #59862 passed with stage
in 8 minutes and 37 seconds
......@@ -88,9 +88,11 @@ find_package(KF5 ${KF5_REQUIRED_VERSION} REQUIRED COMPONENTS
ConfigWidgets
CoreAddons
Crash
I18n
IconThemes
KIO
Parts
TextWidgets
ThreadWeaver
WindowSystem
${optionalComponents}
......@@ -445,6 +447,7 @@ target_link_libraries(okularpart okularcore
KF5::Parts
KF5::Solid
KF5::WindowSystem
KF5::TextWidgets
)
if(KF5Wallet_FOUND)
......
......@@ -18,7 +18,7 @@ ecm_add_app_icon(okular_SRCS ICONS ${ICONS_SRCS})
add_executable(okular ${okular_SRCS})
target_link_libraries(okular KF5::Parts KF5::WindowSystem KF5::Crash)
target_link_libraries(okular KF5::I18n KF5::Parts KF5::WindowSystem KF5::Crash)
if(TARGET KF5::Activities)
target_compile_definitions(okular PUBLIC -DWITH_KACTIVITIES=1)
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment