Bump min deps to Qt 5.5 and ECM/KF 5.18

parent bd1773e2
cmake_minimum_required(VERSION 2.8.12 FATAL_ERROR)
project(svgpart)
set(QT_MIN_VERSION "5.2.0")
set(QT_MIN_VERSION "5.5.0")
set(KF_MIN_VERSION "5.18.0")
find_package(ECM 1.0.0 REQUIRED NO_MODULE)
find_package(ECM ${KF_MIN_VERSION} REQUIRED NO_MODULE)
set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR})
include(KDEInstallDirs)
......@@ -12,7 +13,7 @@ include(KDECompilerSettings NO_POLICY_SCOPE)
include(FeatureSummary)
find_package(Qt5 ${QT_MIN_VERSION} CONFIG REQUIRED COMPONENTS Widgets Svg)
find_package(KF5 REQUIRED COMPONENTS CoreAddons Parts)
find_package(KF5 ${KF_MIN_VERSION} REQUIRED COMPONENTS CoreAddons Parts)
add_definitions(-DTRANSLATION_DOMAIN="svgpart")
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment