Bump min deps to Qt 5.9 & KF 5.53

parent 2d5bd70c
cmake_minimum_required(VERSION 3.0)
project(svgpart)
set(QT_MIN_VERSION "5.5.0")
set(KF_MIN_VERSION "5.18.0")
set(QT_MIN_VERSION "5.9.0")
set(KF_MIN_VERSION "5.53.0")
find_package(ECM ${KF_MIN_VERSION} REQUIRED NO_MODULE)
set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${ECM_MODULE_PATH})
......@@ -17,7 +17,7 @@ find_package(KF5 ${KF_MIN_VERSION} REQUIRED COMPONENTS CoreAddons Parts)
add_definitions(
-DQT_DEPRECATED_WARNINGS
-DQT_DISABLE_DEPRECATED_BEFORE=0x050500
-DQT_DISABLE_DEPRECATED_BEFORE=0x050900
-DQT_NO_URL_CAST_FROM_STRING
)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment