Commit c48056d2 authored by Jan Grulich's avatar Jan Grulich
Browse files

Replace KDE4Support with KDELibs4Support

parent 0601b4c5
project(plasma-networkmanagement)
cmake_minimum_required(VERSION 2.8.6 FATAL_ERROR)
cmake_minimum_required(VERSION 2.8.12 FATAL_ERROR)
set(QT_MIN_VERSION "5.2.0")
set(PLASMA_NM_VERSION 1.0.0)
......@@ -31,7 +31,7 @@ find_package(Qt5 ${QT_MIN_VERSION} CONFIG REQUIRED COMPONENTS
find_package(KF5 REQUIRED
I18n WindowSystem Service Completion WidgetsAddons KIO CoreAddons Wallet ItemViews XmlGui
ConfigWidgets IconThemes Solid DBusAddons Notifications Plasma Declarative Init KDE4Support)
ConfigWidgets IconThemes Solid DBusAddons Notifications Plasma Declarative Init KDELibs4Support)
find_package(KF5NetworkManagerQt)
set_package_properties(KF5NetworkManagerQt PROPERTIES
......
......@@ -32,7 +32,7 @@ target_link_libraries(kde-nm-connection-editor
KF5::Wallet
KF5::ItemViews
KF5::XmlGui
KF5::KDE4Support
KF5::KDELibs4Support
)
if (WITH_MODEMMANAGER_SUPPORT)
......
......@@ -48,7 +48,7 @@ target_link_libraries(kded_networkmanagement
KF5::WindowSystem
KF5::KIOWidgets
KF5::CoreAddons
KF5::KDE4Support
KF5::KDELibs4Support
)
if (WITH_MODEMMANAGER_SUPPORT)
......
......@@ -21,7 +21,7 @@ target_link_libraries(plasmanetworkmanagement-internal
KF5::Completion
KF5::I18n
KF5::IconThemes
KF5::KDE4Support
KF5::KDELibs4Support
KF5::Plasma
KF5::Notifications
Qt5::Xml
......
......@@ -98,7 +98,7 @@ target_link_libraries(plasmanetworkmanagement-editor
KF5::Wallet
KF5::ItemViews
KF5::XmlGui
KF5::KDE4Support
KF5::KDELibs4Support
)
if (WITH_MODEMMANAGER_SUPPORT)
......
......@@ -15,7 +15,7 @@ target_link_libraries(plasmanetworkmanagementwidgets
KF5::I18n
KF5::ConfigWidgets
KF5::WidgetsAddons
KF5::KDE4Support
KF5::KDELibs4Support
)
install( TARGETS plasmanetworkmanagementwidgets DESTINATION ${PLUGIN_INSTALL_DIR}/plugins/designer )
......@@ -25,7 +25,7 @@ target_link_libraries(plasmanetworkmanagement_l2tpui
KF5::WidgetsAddons
KF5::KIOWidgets
KF5::CoreAddons
KF5::KDE4Support
KF5::KDELibs4Support
)
install(TARGETS plasmanetworkmanagement_l2tpui DESTINATION ${PLUGIN_INSTALL_DIR}/plasmanetworkmanagement/vpnuiplugin)
......
......@@ -48,7 +48,7 @@ if (OPENCONNECT_FOUND)
KF5::WidgetsAddons
KF5::KIOWidgets
KF5::CoreAddons
KF5::KDE4Support
KF5::KDELibs4Support
${OPENCONNECT_LIBRARIES}
${maybe_OPENSSL_LIBRARIES}
)
......
......@@ -23,7 +23,7 @@ target_link_libraries(plasmanetworkmanagement_openswanui
KF5::WidgetsAddons
KF5::KIOWidgets
KF5::CoreAddons
KF5::KDE4Support
KF5::KDELibs4Support
)
install(TARGETS plasmanetworkmanagement_openswanui DESTINATION ${PLUGIN_INSTALL_DIR}/plasmanetworkmanagement/vpnuiplugin)
......
......@@ -23,7 +23,7 @@ target_link_libraries(plasmanetworkmanagement_pptpui
KF5::WidgetsAddons
KF5::KIOWidgets
KF5::CoreAddons
KF5::KDE4Support
KF5::KDELibs4Support
)
install(TARGETS plasmanetworkmanagement_pptpui DESTINATION ${PLUGIN_INSTALL_DIR}/plasmanetworkmanagement/vpnuiplugin)
......
......@@ -17,7 +17,7 @@ target_link_libraries(plasmanetworkmanagement_strongswanui
KF5::Service
KF5::I18n
KF5::KIOWidgets
KF5::KDE4Support
KF5::KDELibs4Support
KF5::NetworkManagerQt
)
......
......@@ -24,7 +24,7 @@ target_link_libraries(plasmanetworkmanagement_vpncui
KF5::WidgetsAddons
KF5::KIOWidgets
KF5::CoreAddons
KF5::KDE4Support
KF5::KDELibs4Support
)
install(TARGETS plasmanetworkmanagement_vpncui DESTINATION ${PLUGIN_INSTALL_DIR}/plasmanetworkmanagement/vpnuiplugin)
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment