Commit 642f14ac authored by Albert Astals Cid's avatar Albert Astals Cid

Add a Ubuntu 18.04 CI

It matches quite well our min Qt and KF5 requirements
parent 5e6649c3
build_ubuntu_18_04:
image: ubuntu:bionic
before_script:
- sed -i -e 's/# deb-src/deb-src/g' /etc/apt/sources.list
- apt-get update
- apt-get build-dep --yes --no-install-recommends okular
- apt-get install --yes --no-install-recommends ninja-build libkf5crash-dev
script:
- mkdir -p build && cd build
- cmake -G Ninja ..
- ninja
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment