Commit cac397dd authored by Albert Astals Cid's avatar Albert Astals Cid

Fix wrong porting

We left the code for poppler < 0.22 when we should have left the other since for Qt5 poppler is always > 0.22

BUGS: 374028
parent 2e1a71ff
......@@ -1643,9 +1643,7 @@ bool PDFGenerator::supportsOption( SaveOption option ) const
{
case SaveChanges:
{
// Saving files with /Encrypt is not supported before Poppler 0.22
QMutexLocker locker( userMutex() );
return pdfdoc->isEncrypted() ? false : true;
return true;
}
default: ;
}
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment