Commit b541d8e8 authored by Albert Astals Cid's avatar Albert Astals Cid

Cleanup the debug

parent af652c02
......@@ -32,11 +32,8 @@ if(NOT WIN32)
# query pkg-config asking for a libspectre >= LIBSPECTRE_MINIMUM_VERSION
EXEC_PROGRAM(${PKGCONFIG_EXECUTABLE} ARGS --atleast-version=${LIBSPECTRE_MINIMUM_VERSION} libspectre RETURN_VALUE _return_VALUE OUTPUT_VARIABLE _pkgconfigDevNull )
MESSAGE("THIS IS EXTRA DEBUG ${PKGCONFIG_EXECUTABLE}#${LIBSPECTRE_MINIMUM_VERSION}#${_return_VALUE}#${_pkgconfigDevNull}")
if(_return_VALUE STREQUAL "0")
MESSAGE("_return_VALUE is 0")
set(LIBSPECTRE_INTERNAL_FOUND TRUE)
MESSAGE("LIBSPECTRE_INTERNAL_FOUND ${LIBSPECTRE_INTERNAL_FOUND}")
endif(_return_VALUE STREQUAL "0")
endif(_SpectreLinkFlags)
else(NOT WIN32)
......@@ -48,7 +45,6 @@ else(NOT WIN32)
set(LIBSPECTRE_INTERNAL_FOUND TRUE)
endif(NOT WIN32)
MESSAGE("2LIBSPECTRE_INTERNAL_FOUND ${LIBSPECTRE_INTERNAL_FOUND}")
if (LIBSPECTRE_INTERNAL_FOUND)
set(LIBSPECTRE_LIBRARY ${_SpectreLinkFlags})
......@@ -62,7 +58,6 @@ if (LIBSPECTRE_INTERNAL_FOUND)
endif (LIBSPECTRE_INTERNAL_FOUND)
include(FindPackageHandleStandardArgs)
MESSAGE("find_package_handle_standard_args ${LIBSPECTRE_LIBRARY} ${LIBSPECTRE_INTERNAL_FOUND}")
find_package_handle_standard_args(LibSpectre DEFAULT_MSG LIBSPECTRE_LIBRARY LIBSPECTRE_INTERNAL_FOUND)
# ensure that they are cached
......@@ -70,4 +65,3 @@ set(LIBSPECTRE_INCLUDE_DIR ${LIBSPECTRE_INCLUDE_DIR} CACHE INTERNAL "The libspec
set(LIBSPECTRE_LIBRARY ${LIBSPECTRE_LIBRARY} CACHE INTERNAL "The libspectre library")
endif(LIBSPECTRE_INCLUDE_DIR AND LIBSPECTRE_LIBRARY)
MESSAGE("LIBSPECTRE_FOUND ${LIBSPECTRE_FOUND}")
......@@ -6,7 +6,6 @@ macro_optional_find_package(Poppler)
macro_log_feature(HAVE_POPPLER_0_12_1 "Poppler-Qt4" "A PDF rendering library" "http://poppler.freedesktop.org" FALSE "0.12.1" "Support for PDF files in okular.")
macro_optional_find_package(LibSpectre)
MESSAGE("2LIBSPECTRE_FOUND ${LIBSPECTRE_FOUND}")
macro_log_feature(LIBSPECTRE_FOUND "libspectre" "A PostScript rendering library" "http://libspectre.freedesktop.org/wiki/" FALSE "${LIBSPECTRE_MINIMUM_VERSION}" "Support for PS files in okular.")
macro_optional_find_package(CHM)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment