Commit d169b27e authored by Francis Herne's avatar Francis Herne

Bump supported Python version to 3.8

There were no breaking changes in the final release.
3.8.0-a1 through 3.8.0-b4 were problematic due to
https://bugs.python.org/issue32911 , but the change was reverted.
parent 5696dcb0
......@@ -40,7 +40,7 @@ add_definitions( -DTRANSLATION_DOMAIN=\"kdevpython\" )
# CMake looks for exactly the specified version first and ignores newer versions.
# To avoid that, start looking for the newest supported version and work down.
set(Python_ADDITIONAL_VERSIONS 3.6 3.5 3.4)
set(Python_ADDITIONAL_VERSIONS 3.7 3.6 3.5 3.4)
foreach(_PYTHON_V ${Python_ADDITIONAL_VERSIONS})
find_package(PythonInterp ${_PYTHON_V})
if ( PYTHONINTERP_FOUND )
......@@ -58,7 +58,7 @@ if ( PYTHONINTERP_FOUND AND PYTHON_VERSION_STRING VERSION_GREATER "3.4" )
endif()
if ( NOT PYTHONLIBS_FOUND OR PYTHONLIBS_VERSION_STRING VERSION_LESS "3.4.3" )
message(FATAL_ERROR "Python >= 3.4.3 but < 3.7 with --enable-shared is required to build kdev-python")
message(FATAL_ERROR "Python >= 3.4.3 but < 3.8 with --enable-shared is required to build kdev-python")
endif()
configure_file(kdevpythonversion.h.cmake "${CMAKE_CURRENT_BINARY_DIR}/kdevpythonversion.h" @ONLY)
......
......@@ -11,7 +11,7 @@ related to packaging.
Supported Python versions
-------------------------
Python 2 support was dropped, and we just support the latest 2 to 3 minor
Python 2 support was dropped, and we just support the latest few minor
releases of Python 3 right now.
NOTE: Since we use the upstream CPython parser, compiling against an old
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment