Commit 68d4f469 authored by Michael Reeves's avatar Michael Reeves

update changelog and readme

parent 85ea0e7f
Version 0.10.0 - 2017-01-23
============================
-ported to QT5/KDEFramework5
-depreciated cmake 2.8.12 and 3.0.x support
-abandonded Konqueror specific plugin no longer applicable.
-kde4 support dropped due to extensive changes needed for QT5/KDEFramework5
Version 0.9.98a - 2012-09-11
============================
- Text rendering now with QTextLayout fixes the following issues
......
......@@ -4,10 +4,12 @@ KDiff3-Readme
Port to kf5/Qt5 by Michael Reeves (C) 2016
KDiff3-Version: 0.10.0
Now requires Qt 5.3 or later and KF5 5.5+. Legacy 0.9.94 and earlier builds are not supported.
Now requires Qt 5.3 or later and KF5 5.5+. Legacy 0.9.98 and earlier builds are not supported.
Windows/MacOSX build is untested since port. Builds and runs under kubuntu 16.04 will likely
still work under other Linux/Un*x. konqueror specific plugin is not ported and no longer mantained.
This plugin would only apply to KDE before 4.6 . Support as been removed from main CMakeLists.txt.
still work under other Linux/Un*x. The Konqueror specific plugin is not ported and no longer mantained.
This plugin would only apply to KDE before 4.6. Support as been removed from main CMakeLists.txt.
As of 1/13/17 cmake 3.1+ is the targeted cmake version. cmake 2.8.12 and 3.0.x should work but will be
given best effort support.
These are the original pre kf5/qt5 Readme fallows:
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment