Commit 95344eca authored by Anupam Basak's avatar Anupam Basak

Version 1.0.0

parent f7aa851c
project(pix)
cmake_minimum_required(VERSION 3.0)
set(PIX_VERSION 1.0.0)
project(pix VERSION ${PIX_VERSION})
set(REQUIRED_QT_VERSION 5.10.0)
set(REQUIRED_KF5_VERSION 5.60)
......@@ -17,8 +18,14 @@ include(KDEInstallDirs)
include(KDECompilerSettings NO_POLICY_SCOPE)
include(KDECMakeSettings)
include(ECMInstallIcons)
include(FeatureSummary)
include(ECMAddAppIcon)
include(ECMSetupVersion)
include(FeatureSummary)
ecm_setup_version(${PIX_VERSION}
VARIABLE_PREFIX PIX
VERSION_HEADER "${CMAKE_CURRENT_BINARY_DIR}/pix_version.h"
)
if (ANDROID)
find_package(Qt5 ${REQUIRED_QT_VERSION} REQUIRED COMPONENTS AndroidExtras)
......
......@@ -33,6 +33,8 @@ along with this program. If not, see <http://www.gnu.org/licenses/>.
#include <QJsonDocument>
#include <QJsonObject>
#include "../pix_version.h"
#if (defined (Q_OS_LINUX) && !defined (Q_OS_ANDROID))
#include <MauiKit/utils.h>
#include <MauiKit/fmh.h>
......@@ -119,7 +121,7 @@ inline const static auto NotifyDir = QUrl::fromLocalFile(QStandardPaths::writabl
inline const static QString appName = QStringLiteral("pix");
inline const static QString displayName = QStringLiteral("Pix");
inline const static QString version = "1.0";
inline const static QString version = PIX_VERSION_STRING;
inline const static QString description = QStringLiteral("Image Viewer");
inline const static QString orgName = QStringLiteral("Maui");
inline const static QString orgDomain = QStringLiteral("org.maui.pix");
......
  • Can we get a git tag for 1.0.0?

  • Yeah.. Sure.. We are making some final tests before tagging.. Just wanted to be sure that it is finally ready to be tagged..

    Will do it surely.

Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment