Commit 54f66a0a authored by Milian Wolff's avatar Milian Wolff
Browse files

Raise libkomparediff2 version requirement to 5.1

This allows us to unconditionally compile with the strict string
conversion rules. I cannot find an exact time when this got released
but it's been regularly released with higher version numbers for many
years by now.
parent 2cf889a6
find_package(LibKompareDiff2 5.0 CONFIG)
find_package(LibKompareDiff2 5.1 CONFIG)
set_package_properties(LibKompareDiff2 PROPERTIES
PURPOSE "Required for building the patch review plugin."
TYPE REQUIRED
......@@ -19,13 +19,6 @@ endif()
add_definitions(-DTRANSLATION_DOMAIN=\"kdevpatchreview\")
kde_enable_exceptions()
if(LibKompareDiff2_VERSION VERSION_LESS 5.1)
remove_definitions(
-DQT_NO_CAST_FROM_ASCII
-DQT_NO_SIGNALS_SLOTS_KEYWORDS
)
endif()
set(patchreview_PART_SRCS
patchreview.cpp
patchhighlighter.cpp
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment