appimage: build 5.6, bump kf/rs/plasma/okteta to 5.73/20.08.0/5.19.4/0.26.4

GIT_SILENT
parent e1c6fa44
Pipeline #30934 passed with stage
in 44 minutes and 3 seconds
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7f649eb5..19661a2f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -39,6 +39,13 @@ function(generate_binary_resource target outfile)
set(RESOURCE_FILE ${RESOURCES_WORKING_DIR}/breeze-${target}.qrc)
set(BINARY_RESOURCE_FILE ${CMAKE_CURRENT_BINARY_DIR}/breeze-${target}.rcc)
+ # Use $<IF:$<BOOL:${MSVC}>,PATH,LD_LIBRARY_PATH> instead of ${pathVarName} once CMake 3.8 is minimum
+ if(MSVC)
+ set(pathVarName PATH)
+ else()
+ set(pathVarName LD_LIBRARY_PATH)
+ endif()
+
get_target_property(QT_RCC_EXECUTABLE Qt5::rcc LOCATION)
add_custom_target(breeze-${target}-mkdir
@@ -53,7 +60,7 @@ function(generate_binary_resource target outfile)
${RESOURCES_WORKING_DIR}/CMakeLists.txt
COMMAND ${QT_RCC_EXECUTABLE} --project -o ${CMAKE_CURRENT_BINARY_DIR}/tmp.qrc
COMMAND ${CMAKE_COMMAND} -E env
- $<IF:$<BOOL:${MSVC}>,PATH,LD_LIBRARY_PATH>=$<TARGET_FILE_DIR:Qt5::Core>
+ ${pathVarName}=$<TARGET_FILE_DIR:Qt5::Core>
$<TARGET_FILE:qrcAlias> -i ${CMAKE_CURRENT_BINARY_DIR}/tmp.qrc -o ${RESOURCE_FILE}
WORKING_DIRECTORY ${RESOURCES_WORKING_DIR}
......@@ -22,17 +22,17 @@ SCRIPT_DIR="$(cd "$(dirname "${BASH_SOURCE[0]}")" && pwd)"
QTDIR=/opt/qt5
if [ -z "$KDEVELOP_VERSION" ]; then
KDEVELOP_VERSION=5.5
KDEVELOP_VERSION=5.6
fi
if [ -z "$KDEV_PG_QT_VERSION" ]; then
KDEV_PG_QT_VERSION=v2.2.1
fi
# remove breezeicons-compatcmake3.6.patch for >5.69.0
KF5_VERSION=v5.69.0
PLASMA_VERSION=v5.18.5
KDE_RELEASESERVICE_VERSION=v20.04.1
KF5_VERSION=v5.73.0
LIBKSYSGUARD_VERSION=v5.18.5 # 5.19 needs Qt 5.14
BREEZESTYLE_VERSION=v5.19.4
KDE_RELEASESERVICE_VERSION=v20.08.0
GRANTLEE_VERSION=v5.2.0
OKTETA_VERSION=v0.26.3
OKTETA_VERSION=v0.26.4
export LLVM_ROOT=/opt/llvm/
export PATH=/opt/rh/python27/root/usr/bin/:$PATH
......@@ -190,24 +190,23 @@ build_framework kparts
build_framework kitemmodels
build_framework threadweaver
build_framework attica
build_framework kpackage
build_framework knewstuff
build_framework syntax-highlighting
build_framework ktexteditor
build_framework kpackage
build_framework kdeclarative
build_framework kcmutils
(PATCH_FILE=$SCRIPT_DIR/knotifications_no_phonon.patch build_framework knotifications)
(PATCH_FILE=$SCRIPT_DIR/knotifyconfig_no_phonon.patch build_framework knotifyconfig)
build_framework kdoctools
(PATCH_FILE=$SCRIPT_DIR/breezeicons-compatcmake3.6.patch build_framework breeze-icons -DBINARY_ICONS_RESOURCE=1)
build_framework breeze-icons -DBINARY_ICONS_RESOURCE=1
build_framework kpty
build_framework kinit
fi
# KDE Plasma
build_kde_project plasma/libksysguard $PLASMA_VERSION
build_kde_project plasma/kdecoration $PLASMA_VERSION # needed by breeze
(PATCH_FILE=$SCRIPT_DIR/breeze-noconstexpr.patch build_kde_project plasma/breeze $PLASMA_VERSION)
build_kde_project plasma/libksysguard $LIBKSYSGUARD_VERSION
(PATCH_FILE=$SCRIPT_DIR/breeze-noconstexpr.patch build_kde_project plasma/breeze $BREEZESTYLE_VERSION -DWITH_DECORATIONS=OFF -DWITH_WALLPAPERS=OFF)
# KDE Applications
build_kde_project sdk/libkomparediff2 $KDE_RELEASESERVICE_VERSION
......
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 155422d..59b6768 100644
index a96b1e5..3058ee8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -35,15 +35,16 @@ find_package(Canberra)
set_package_properties(Canberra PROPERTIES
PURPOSE "Needed to preview notification sounds"
@@ -37,10 +37,10 @@ set_package_properties(Canberra PROPERTIES
TYPE OPTIONAL)
+set(Canberra_FOUND FALSE)
if (Canberra_FOUND)
add_definitions(-DHAVE_CANBERRA)
else()
if (NOT Canberra_FOUND)
# This is REQUIRED since you cannot tell CMake "either one of those two optional ones are required"
- find_package(Phonon4Qt5 4.6.60 NO_MODULE REQUIRED)
- set_package_properties(Phonon4Qt5 PROPERTIES
- DESCRIPTION "Qt-based audio library"
- PURPOSE "Needed to preview notification sounds when Canberra isn't available")
- add_definitions(-DHAVE_PHONON4QT5)
+# find_package(Phonon4Qt5 4.6.60 NO_MODULE REQUIRED)
+# set_package_properties(Phonon4Qt5 PROPERTIES
+# DESCRIPTION "Qt-based audio library"
+# PURPOSE "Needed to preview notification sounds when Canberra isn't available")
+# add_definitions(-DHAVE_PHONON4QT5)
endif()
# Includes
diff --git a/src/knotify-config.h.cmake b/src/knotify-config.h.cmake
index 1794afc..7917612 100644
--- a/src/knotify-config.h.cmake
+++ b/src/knotify-config.h.cmake
@@ -1,7 +1,7 @@
#ifndef KNOTIFY_CONFIG_H
#define KNOTIFY_CONFIG_H
-#cmakedefine01 HAVE_PHONON
+#cmakedefine HAVE_PHONON
#endif /* KNOTIFY_CONFIG_H */
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment