Commit 9df7cdb0 authored by Alexander Potashev's avatar Alexander Potashev

ruby: Remove #ifdef which is always true

We support only Ruby 1.9 and newer, and RUBY_INIT_STACK was introduced
in Ruby 1.8.6.
parent 515b141d
...@@ -94,9 +94,7 @@ void RubyInterpreter::initRuby() ...@@ -94,9 +94,7 @@ void RubyInterpreter::initRuby()
#endif #endif
d = new RubyInterpreterPrivate(); d = new RubyInterpreterPrivate();
#ifdef RUBY_INIT_STACK
RUBY_INIT_STACK RUBY_INIT_STACK
#endif
ruby_init(); ruby_init();
ruby_init_loadpath(); ruby_init_loadpath();
rb_define_global_function("require", (VALUE (*)(...))RubyInterpreter::require, 1); rb_define_global_function("require", (VALUE (*)(...))RubyInterpreter::require, 1);
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment