Commit b46ee111 authored by Boudewijn Rempt's avatar Boudewijn Rempt

Changes the minimal SIP version required by Cmake from 4.18 to 4.19.13

Krita Python plugin compilation fails when SIP is in the version lower than 4.19.9. Since the file [source directory]/dev-tools/python/dev-requirements.txt mentions the minimum version required to be 4.19.13, this patch sets Cmake requirement to the same version.

Differential Revision:https://phabricator.kde.org/D18799
parent 0d8b6bd6
...@@ -571,7 +571,7 @@ set_package_properties(PythonLibrary PROPERTIES ...@@ -571,7 +571,7 @@ set_package_properties(PythonLibrary PROPERTIES
PURPOSE "Required by the Krita PyQt plugin") PURPOSE "Required by the Krita PyQt plugin")
macro_bool_to_01(PYTHONLIBS_FOUND HAVE_PYTHONLIBS) macro_bool_to_01(PYTHONLIBS_FOUND HAVE_PYTHONLIBS)
find_package(SIP "4.18.0") find_package(SIP "4.19.13")
set_package_properties(SIP PROPERTIES set_package_properties(SIP PROPERTIES
DESCRIPTION "Support for generating SIP Python bindings" DESCRIPTION "Support for generating SIP Python bindings"
URL "https://www.riverbankcomputing.com/software/sip/download" URL "https://www.riverbankcomputing.com/software/sip/download"
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment