Commit 248a6856 authored by Laurent Montel's avatar Laurent Montel 😁
Browse files

Prepare to adapt build system against qt6

parent 79b09d72
Pipeline #168535 passed with stage
in 39 seconds
......@@ -3,7 +3,7 @@ cmake_minimum_required(VERSION 3.16)
project(audiocd VERSION "5.0.0")
set(QT_MIN_VERSION "5.15.0")
set(KF_MIN_VERSION "5.85.0")
set(KF_MIN_VERSION "5.90.0")
find_package(ECM ${KF_MIN_VERSION} REQUIRED NO_MODULE)
set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} "${CMAKE_CURRENT_SOURCE_DIR}/cmake")
......@@ -21,7 +21,7 @@ include(CheckStructHasMember)
include(FeatureSummary)
include(KDEGitCommitHooks)
find_package(Qt5 ${QT_MIN_VERSION} REQUIRED COMPONENTS Core Widgets)
find_package(Qt${QT_MAJOR_VERSION} ${QT_MIN_VERSION} REQUIRED COMPONENTS Core Widgets)
find_package(KF5 ${KF_MIN_VERSION} REQUIRED COMPONENTS
Config
......
......@@ -21,7 +21,7 @@ target_link_libraries(kcm_audiocd
install(TARGETS kcm_audiocd DESTINATION ${KDE_INSTALL_PLUGINDIR})
install(FILES audiocd.desktop DESTINATION ${KDE_INSTALL_KSERVICES5DIR})
install(FILES audiocd.desktop DESTINATION ${KDE_INSTALL_KSERVICESDIR})
########### add handbook ################
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment