Members of the KDE Community are recommended to subscribe to the kde-community mailing list at https://mail.kde.org/mailman/listinfo/kde-community to allow them to participate in important discussions and receive other important announcements

Use KF_MIN_VERSION also for ECM, given it's released as part of KF now

parent e15a324e
......@@ -2,19 +2,19 @@ cmake_minimum_required(VERSION 3.0)
project(audiocd)
set(PROJECT_VERSION "19.04.0")
set(QT_MIN_VERSION "5.9.0")
set(KF_MIN_VERSION "5.24.0")
# ECM setup
include(FeatureSummary)
find_package(ECM 5.24.0 NO_MODULE)
set_package_properties(ECM PROPERTIES TYPE REQUIRED DESCRIPTION "Extra CMake Modules." URL "https://projects.kde.org/projects/kdesupport/extra-cmake-modules")
set(CMAKE_MODULE_PATH "${ECM_MODULE_PATH}" "${CMAKE_CURRENT_SOURCE_DIR}/cmake")
set(PROJECT_VERSION "19.04.0")
set(KF5_DEP_VERSION "5.24.0") # handled by release scripts
set(REQUIRED_QT_VERSION "5.9.0")
find_package(ECM ${KF_MIN_VERSION} REQUIRED NO_MODULE)
set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} "${CMAKE_CURRENT_SOURCE_DIR}/cmake")
find_package(Qt5 ${REQUIRED_QT_VERSION} REQUIRED COMPONENTS Core Widgets)
find_package(Qt5 ${QT_MIN_VERSION} REQUIRED COMPONENTS Core Widgets)
find_package(KF5 ${KF5_DEP_VERSION} REQUIRED COMPONENTS
find_package(KF5 ${KF_MIN_VERSION} REQUIRED COMPONENTS
Config
I18n
DocTools
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment