Bump min deps to Qt 5.9 & KF 5.53

parent 25c20e31
......@@ -10,8 +10,8 @@ set(KDE_APPLICATIONS_VERSION "${KDE_APPLICATIONS_VERSION_MAJOR}.${KDE_APPLICATIO
set(PROJECT_VERSION ${KDE_APPLICATIONS_VERSION})
set(QT_MIN_VERSION "5.6.0")
set(KF5_MIN_VERSION "5.31.0")
set(QT_MIN_VERSION "5.9.0")
set(KF5_MIN_VERSION "5.53.0")
find_package(ECM ${KF5_MIN_VERSION} REQUIRED NO_MODULE)
set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${ECM_MODULE_PATH})
......@@ -65,7 +65,7 @@ configure_file(config.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config.h)
add_definitions(
-DQT_DEPRECATED_WARNINGS
-DQT_DISABLE_DEPRECATED_BEFORE=0x050600
-DQT_DISABLE_DEPRECATED_BEFORE=0x050900
-DQT_USE_QSTRINGBUILDER
-DQT_NO_CAST_TO_ASCII
# -DQT_NO_CAST_FROM_ASCII
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment