Members of the KDE Community are recommended to subscribe to the kde-community mailing list at https://mail.kde.org/mailman/listinfo/kde-community to allow them to participate in important discussions and receive other important announcements

Commit 5f2757ae authored by Luigi Toscano's avatar Luigi Toscano

Q_FALLTHROUGH is only available from Qt>=5.8

parent 3dc41085
......@@ -29,6 +29,7 @@
#include <QDir>
#include <QBuffer>
#include <QtGlobal>
#include "tag.h"
#include "searchplaylist.h"
......@@ -83,7 +84,9 @@ void Cache::loadPlaylists(PlaylistCollection *collection) // static
switch(version) {
case 3:
dataStreamVersion = QDataStream::Qt_4_3;
#if QT_VERSION >= QT_VERSION_CHECK(5, 8, 0)
Q_FALLTHROUGH();
#endif
case 1:
case 2:
......@@ -320,7 +323,9 @@ bool Cache::prepareToLoadCachedItems()
switch(version) {
case 2:
dataStreamVersion = CacheDataStream::Qt_4_3;
#if QT_VERSION >= QT_VERSION_CHECK(5, 8, 0)
Q_FALLTHROUGH();
#endif
// Other than that we're compatible with cache v1, so fallthrough
// to setCacheVersion
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment