Commit 18408543 authored by Leslie Zhai's avatar Leslie Zhai

Consider about old Linux system

Bug from K3b Application 17.04, it depends on KF5, thanks for
Michał Małek migration job! and right now it supports to build for
FreeBSD using Clang compiler, I would enable C++11 or even C++17
at that time I will not consider about old system any more.

CCBUG: 380067
parent 41e6f110
......@@ -622,13 +622,11 @@ bool K3b::IsoImager::addMkisofsParameters( bool printSize )
}
}
if (filesGreaterThan2Gb) {
emit infoMessage(i18n("Found files bigger than 2 GB. These files will be fully accessible."),
MessageInfo);
// in genisoimage 1.1.3 "they" silently introduced this aweful parameter
if (d->mkisofsBin->hasFeature("genisoimage") && d->mkisofsBin->version() >= K3b::Version(1, 1, 3))
if (filesGreaterThan2Gb && d->mkisofsBin->hasFeature("genisoimage") && d->mkisofsBin->version() >= K3b::Version(1, 1, 3)) {
*m_process << "-allow-limited-size";
emit infoMessage(i18n("Found files bigger than 2 GB. These files will be fully accessible."),
MessageInfo);
}
bool udf = m_doc->isoOptions().createUdf();
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment