get rid deprecated qt5_use_modules

parent 66e82636
......@@ -81,7 +81,7 @@ include(CheckIncludeFiles)
check_include_files(malloc.h HAVE_MALLOC_H)
check_include_files(pthread.h HAVE_PTHREAD_H)
find_package(Qt5 REQUIRED COMPONENTS Core DBus Widgets Svg Quick )
find_package(Qt5 REQUIRED COMPONENTS Core DBus Widgets Svg Quick Concurrent QuickWidgets)
find_package(Qt5 OPTIONAL_COMPONENTS WebKitWidgets QUIET)
find_package(KF5 5.23.0 OPTIONAL_COMPONENTS XmlGui QUIET)
......
......@@ -9,9 +9,8 @@ set(kdenlive_render_SRCS
add_executable(kdenlive_render ${kdenlive_render_SRCS})
ecm_mark_nongui_executable(kdenlive_render)
qt5_use_modules(kdenlive_render Widgets Concurrent DBus)
target_link_libraries(kdenlive_render
Qt5::Core Qt5::DBus
${QT_LIBRARIES}
${Qt5_LIBRARIES}
)
......
......@@ -288,6 +288,9 @@ target_link_libraries(kdenliveLib
KF5::Crash
KF5::Solid
Qt5::Svg
Qt5::Quick
Qt5::QuickWidgets
Qt5::Concurrent
${OPENGL_LIBRARIES}
${OPENGLES_LIBRARIES}
${MLT_LIBRARIES}
......@@ -304,8 +307,6 @@ if (KF5_FILEMETADATA)
target_link_libraries(kdenliveLib KF5::FileMetaData)
endif()
qt5_use_modules( kdenliveLib Widgets Concurrent Qml Quick QuickWidgets)
if (Qt5WebKitWidgets_FOUND)
message(STATUS "Found Qt5 WebKitWidgets. You can use your Freesound.org credentials to download files")
add_definitions(-DQT5_USE_WEBKIT)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment