Commit d5072c30 authored by Jean-Baptiste Mardelle's avatar Jean-Baptiste Mardelle
Browse files

Add missing patch files

parent 6d776ac8
Pipeline #51997 passed with stage
in 10 minutes and 26 seconds
......@@ -235,8 +235,8 @@ InstallKF5Component(kxmlgui ${KF5_VERSION} ""
InstallKF5Component(kbookmarks ${KF5_VERSION} "" "")
InstallKF5Component(kdoctools ${KF5_VERSION} "" "")
InstallKF5Component(kimageformats ${KF5_VERSION} "" "")
InstallKF5Component(knotifyconfig ${KF5_VERSION} "" "knotifyconfig-drop-phonon.patch")
InstallKF5Component(knotifications ${KF5_VERSION} "" "knotifications-drop-phonon.patch")
InstallKF5Component(knotifyconfig ${KF5_VERSION} "" "knotifyconfig-drop-phonon.diff")
InstallKF5Component(knotifications ${KF5_VERSION} "" "knotifications-drop-phonon.diff")
InstallKF5Component(kjobwidgets ${KF5_VERSION} "" "")
InstallKF5Component(sonnet ${KF5_VERSION} "" "")
InstallKF5Component(ktextwidgets ${KF5_VERSION} "" "")
......
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4d55dcb..47e164a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -93,11 +93,11 @@ if (NOT WIN32 AND NOT ANDROID)
add_definitions(-DHAVE_CANBERRA)
else()
# This is REQUIRED since you cannot tell CMake "either one of those two optional ones are required"
- find_package(Phonon4Qt5 4.6.60 NO_MODULE REQUIRED)
- set_package_properties(Phonon4Qt5 PROPERTIES
- DESCRIPTION "Qt-based audio library"
- PURPOSE "Needed to build audio notification support when Canberra isn't available")
- add_definitions(-DHAVE_PHONON4QT5)
+# find_package(Phonon4Qt5 4.6.60 NO_MODULE REQUIRED)
+# set_package_properties(Phonon4Qt5 PROPERTIES
+# DESCRIPTION "Qt-based audio library"
+# PURPOSE "Needed to build audio notification support when Canberra isn't available")
+# add_definitions(-DHAVE_PHONON4QT5)
endif()
endif()
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bcd3f7b..0005250 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -37,10 +37,10 @@ set_package_properties(Canberra PROPERTIES
TYPE OPTIONAL)
if (NOT Canberra_FOUND)
# This is REQUIRED since you cannot tell CMake "either one of those two optional ones are required"
- find_package(Phonon4Qt5 4.6.60 NO_MODULE REQUIRED)
- set_package_properties(Phonon4Qt5 PROPERTIES
- DESCRIPTION "Qt-based audio library"
- PURPOSE "Needed to preview notification sounds when Canberra isn't available")
+# find_package(Phonon4Qt5 4.6.60 NO_MODULE REQUIRED)
+# set_package_properties(Phonon4Qt5 PROPERTIES
+# DESCRIPTION "Qt-based audio library"
+# PURPOSE "Needed to preview notification sounds when Canberra isn't available")
endif()
# Includes
diff --git a/src/knotify-config.h.cmake b/src/knotify-config.h.cmake
index e42fc49..241a0d6 100644
--- a/src/knotify-config.h.cmake
+++ b/src/knotify-config.h.cmake
@@ -2,7 +2,6 @@
#define KNOTIFY_CONFIG_H
#cmakedefine HAVE_CANBERRA
-#cmakedefine HAVE_PHONON
#endif /* KNOTIFY_CONFIG_H */
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment