Commit 9c62631d authored by Nicolas Fella's avatar Nicolas Fella Committed by Nicolas Fella

[Android] Don't force TLS version

Summary:
Use the default configuration from Android

BUG: 400883

Test Plan: Pairing still works

Reviewers: #kde_connect, albertvaka

Reviewed By: #kde_connect, albertvaka

Subscribers: albertvaka, thomasp, kdeconnect

Tags: #kde_connect

Differential Revision: https://phabricator.kde.org/D18219
parent ce387108
......@@ -204,8 +204,6 @@ public class SslHelper {
private static void configureSslSocket(SSLSocket socket, boolean isDeviceTrusted, boolean isClient) throws SocketException {
socket.setEnabledProtocols(new String[]{"TLSv1"}); //Newer TLS versions are only supported on API 16+
// These cipher suites are most common of them that are accepted by kde and android during handshake
ArrayList<String> supportedCiphers = new ArrayList<>();
if (Build.VERSION.SDK_INT >= Build.VERSION_CODES.LOLLIPOP) {
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment