Commit 21ee9525 authored by Stefan Brüns's avatar Stefan Brüns
Browse files

smb: Remove obsolete KDNSSD version check and define

KF 5.66 is required, and the code dependent on the define was removed
with commit 41397521 ("add initial wsdiscovery support").
parent a8d4ff01
......@@ -195,12 +195,6 @@ if(NOT WIN32)
endif()
endif()
# KDNSSD before 5.54 suffers from a race condition in avahi's dbus API and
# ideally should not be used in ways that can deadlock a slave.
if(${KF5DNSSD_FOUND} AND ${KF5DNSSD_VERSION} VERSION_GREATER "5.53")
set(HAVE_KDNSSD_WITH_SIGNAL_RACE_PROTECTION TRUE)
endif()
if(SAMBA_FOUND)
add_subdirectory(smb)
endif()
......
......@@ -14,6 +14,3 @@
* Using the definition from this project so as to be independent of Plasma.
*/
#define KDE_VERSION_STRING "@PROJECT_VERSION@"
/* kdnssd with signal race protection */
#cmakedefine HAVE_KDNSSD_WITH_SIGNAL_RACE_PROTECTION 1
......@@ -16,9 +16,6 @@ endif()
add_feature_info("Internal KDSoapWSDiscoveryClient" INTERNAL_WSDCLIENT
"Building using internal client because a system-provided version could not be found.")
add_feature_info("SMB DNS-SD Discovery" HAVE_KDNSSD_WITH_SIGNAL_RACE_PROTECTION
"Discover SMB hosts via DNS-SD/Avahi/Bonjour. KF5DNSSD >= 5.54 is required to support this.")
find_package(Threads REQUIRED)
add_definitions(-DTRANSLATION_DOMAIN=\"kio5_smb\")
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment